Jump to content
Korean Random
Sign in to follow this  
avmir73

[1.4.0.0] Инерция камеры в снайперском режиме на ПТ без ручника

Recommended Posts

После выхода обновы 1.4.0.0, PMOD перестал отключать ручник ПТ в снайперском режиме.

Я вспомнил, что подобная фича есть в родном XVM и попытался настроить...

Вроде бы все работает, но камера постоянно "убегает" дальше, чем нужно было повернуть ствол и ее приходится возвращать...

Может есть какая-нибудь настройка?

Share this post


Link to post

Short link
Share on other sites

@avmir73 

 

В 20.05.2017 в 21:57, night_dragon_on сказал:

// TODO: English comments
// Отключение предела вращения камеры в снайперском прицеле для техники с ограниченными УГН (углами горизонтальной наводки) орудия. 
"noCameraLimit": {
  // true - enable.
  // true - включить.
  "enabled": false, 
  // "custom" - отключение ограничения камеры;
  // "hotkey" - отключение ограничения камеры с зажатой правой кнопкой мыши;
  // "full" - отключение ограничения камеры и фиксации корпуса (включается вручную клавишей "x");
  "mode": "hotkey"
}

 

Цитата

Первый режим - отключаем ограничение вращения камеры, в процессе перемещения корпус техники следует за прицелом на всем протяжении движения; второй режим - отключаем ограничение вращения камеры, в процессе перемещения орудие следует за прицелом до ограничения УГН-ов, далее вращаться будет только камера; ну и третий режим - будет фиксироваться положение ствола и отключится ограничение вращения камеры (режим работы камеры как на технике без ограничения УГН).

 

Share this post


Link to post

Short link
Share on other sites
6 часов назад, night_dragon_on сказал:

Первый режим - отключаем ограничение вращения камеры, в процессе перемещения корпус техники следует за прицелом на всем протяжении движения;

 

 

Ничего подобного не происходит... Камера поворачивается, а корпус - нет.

В режиме full вращается и корпус и камера, но они по инерции проскакивают необходимый угол и приходится возвращать камеру (и корпус)...

Share this post


Link to post

Short link
Share on other sites

@avmir73 а сам модуль выключен? (он выключен по умолчанию). Я выставил знач. "custom" - как работало, так и работает без изменений.

 

проверь, "enabled": true должно быть

"full" - тоже работает. Двигаешь камеру - за камерой подтягивается корпус. По "х" отключается.

Share this post


Link to post

Short link
Share on other sites
1 час назад, HEKPOMAHT сказал:

"full" - тоже работает. Двигаешь камеру - за камерой подтягивается корпус. По "х" отключается.

 

Вот и я про что! Он подтягивается и перескакивает далече)

Share this post


Link to post

Short link
Share on other sites
15 часов назад, avmir73 сказал:

После выхода обновы 1.4.0.0, PMOD перестал отключать ручник ПТ в снайперском режиме

У меня все работает,скорее всего просто обновится до pmod_1.38.2.нужно.

Share this post


Link to post

Short link
Share on other sites
4 минуты назад, Slava7572 сказал:

У меня все работает,скорее всего просто обновится до pmod_1.38.2.нужно.

1.38.3 стоит...

А за проверку спасибо! Может, что-то конфликтует... Буду проверять...

Edited by avmir73

Share this post


Link to post

Short link
Share on other sites
2 часа назад, avmir73 сказал:

Он подтягивается и перескакивает далече)

а в чём затыка, центр между угн не поймать или в чём? он так и должен работать с "full": сместил камеру за лимиты, остановил - корпус сам подтянулся. На быстрых пт может и перескакивает, на медленных вряд ли.

14 минут назад, avmir73 сказал:

Может, что-то конфликтует... Буду проверять...

python.log проверяй - он тебе поведает таинство конфликтов или сюда прикрепи.

Share this post


Link to post

Short link
Share on other sites
21 минуту назад, avmir73 сказал:

1.38.3 стоит...

Да,сегодня добавили.

Share this post


Link to post

Short link
Share on other sites
Только что, Slava7572 сказал:

Да,сегодня добавили.

8-го

Share this post


Link to post

Short link
Share on other sites
3 минуты назад, avmir73 сказал:

8-го

сборки у них такие,число вижу,вчера запускал,38.2 загрузился.

Share this post


Link to post

Short link
Share on other sites

Сейчас наступила путаница... Клиент как-то незаметно обновился до 1.4.0.1... Вообще ни один мод не работает...

Если ситуация с ручником повторится, я обязательно напишу и логи приложу.

Еще конфиг настроить с горем пополам я могу, а вот логи... темный лес...

Питон не мой язык (

Share this post


Link to post

Short link
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×