Jump to content
Korean Random
StranikS_Scan

Мод на отключение загрузки эмблем кланов для борьбы с фризами и зависаниями клиента

Recommended Posts

[WARNING] (scripts/client/account_helpers/CustomFilesCache.py, 33): Method "__run_download" takes too much time 10.1599998474
Наблюдаю такое в 0.9.6, фикс пока не ставил. По ходу только хуже стало, в 0.9.5 такого не было. Фикс актуален однозначно.

 

У меня почему то даже с ним такое: 

[WARNING] (scripts/client/account_helpers/CustomFilesCache.py, 33): Method "__run_read" takes too much time 0.226999998093

Share this post


Link to post

Short link
Share on other sites

У меня почему то даже с ним такое: 

[WARNING] (scripts/client/account_helpers/CustomFilesCache.py, 33): Method "__run_read" takes too much time 0.226999998093

 

Слава, читай первый пост внимательно, там разве написано - "это фикс убирает "...Method "__run_read"..." ?

 

Нет. Он только блочит загрузку эмблем, а другие обращения к этому серверу он не ограничивает и не блокирует.

А разве загрузка иконок не асинхронна? Как она может вызывать подлагивания?

 

А с чего ты решил что зависание вызывает сама загрузка? Есть кучу и другого сопутствующего эмблемам кода, да и сами эмблемы могут быть проблемой. Я не разбирался, отрубил загрузку и всё. Проблема исчезла.

Share this post


Link to post

Short link
Share on other sites

что прописать чтобы не загружались отличительные отметки (стволы орудий)?

Edited by VictorSoprano

Share this post


Link to post

Short link
Share on other sites

что прописать чтобы не загружались отличительные отметки (стволы орудий)?

 

Они из клиенте берутся, с сервера она не грузятся. Картинки имеется ввиду.

Edited by StranikS_Scan

Share this post


Link to post

Short link
Share on other sites

 

В технологии и в результате. Мод в данной теме не дает клиенту грузить картинки с сервера, он блокирует обращения к серверу, со всеми вытекающими. А мод по ссылке убирает иконки с танка. 

Share this post


Link to post

Short link
Share on other sites

Проверил на 0.9.7 - работает. Обновление не требуется.

Спасибо.

Share this post


Link to post

Short link
Share on other sites

Меня спасает данный мод,после обновы 9.7 забыл что стоял он на 9.6 помучился со фризами.после установки все ок.Спасибо за данный скриптик.

Edited by Volod

Share this post


Link to post

Short link
Share on other sites

WG переработала логику - теперь в реплеях логотипы не отображаются.

Только в бою.

Share this post


Link to post

Short link
Share on other sites

WG переработала логику - теперь в реплеях логотипы не отображаются.

Только в бою.

 

Сомнительное утверждение, т.к. клиенту как бы по фиг реплей там или нет, он если может то грузит инфу с серверов, если не может - то не грузит.

 

Проверим.

Share this post


Link to post

Short link
Share on other sites

Сомнительное утверждение, т.к. клиенту как бы по фиг реплей там или нет, он если может то грузит инфу с серверов, если не может - то не грузит.

 

Проверим.

Либо оно верно, либо у них сурово глючит этот сервис.

Спецом проверял в 3 боях и куче реплеев.

Да, мод в 9.8 работает.

Share this post


Link to post

Short link
Share on other sites

 

 

Проверим.
 

Результат сообщите plz, можно использовать в 098 или стоит ждать обновления?

Share this post


Link to post

Short link
Share on other sites

Результат сообщите plz, можно использовать в 098 или стоит ждать обновления?

Можно.

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

Автор, а может такое быть? С этим модом, через определённое время клиент просто начинает жутко тормозить, падает фпс, с каждым боем всё больше. Начинаешь сессию с фпс 60-70, через 20 боёв - уже 30фпс, потом ещё хуже. В конце концов просто слетает игра. Убрал этот мод, и всё норм. Проверьте, плиз.

  • Upvote 1
  • Downvote 3

Share this post


Link to post

Short link
Share on other sites

Автор, а может такое быть? С этим модом, через определённое время клиент просто начинает жутко тормозить, падает фпс, с каждым боем всё больше. Начинаешь сессию с фпс 60-70, через 20 боёв - уже 30фпс, потом ещё хуже. В конце концов просто слетает игра. Убрал этот мод, и всё норм. Проверьте, плиз.

 

Нет, не может.

Share this post


Link to post

Short link
Share on other sites

А как должен работать "Маркер упреждения"?

У меня когда он включается, то он находится просто по центру подсвеченной техники.

Share this post


Link to post

Short link
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×