Jump to content
Korean Random
Sign in to follow this  
scyorkie

{{xvm-stat}} not working?

Recommended Posts

In default markersAliveNormal.xc > def > rating > alpha, you see this: "{{xvm-stat?100|0}}"

I assumed that this meant if you didn't have XVM statistics activated, you wouldn't see the "rating" field at all.

So I copied that part for my own version of the "rating" field, but realised that the field still shows up (just in white) when I play on my brother's non-XVM account. [screenshot]

Is the macro not working, or am I understanding it wrong?

markers.zip

Edited by scyorkie

Share this post


Link to post

Short link
Share on other sites

It was also in playerPanels.

I thought it works like "no stats for this player, exitting", but your version is better.

Yeah, SHOULD.

I can't find it in macros.txt nor readme-en.txt, maybe it doesn't work now?

Share this post


Link to post

Short link
Share on other sites

It's in the 2nd table in macros.txt -- global macros.

(Ah yes it's also in the default playersPanel.xc, but just not mine.)

Share this post


Link to post

Short link
Share on other sites

It works when stats are completely turned off, rather than just being inactive. But I don't know whether it's intended action or a bug in the latter scenario.

Edited by konrad509
  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

So here's a follow up issue.

 

This is how my vehicle fields are formatted in statisticForm.xc:

 

"formatLeftVehicle": "<font size='12'>{{vehicle}}</font><font face='mono' size='11' color='#3c3c3c'> {{xvm-stat?{{kb%3d~k|---k}}}} <font color='{{c:wn8}}'>{{xvm-stat?{{wn8%4d|----}}}}</font> <font color='{{c:winrate}}'>{{xvm-stat?{{winrate%2d~%|--%}}}}</font></font>",

 

"formatRightVehicle": "<font face='mono' size='11' color='#3c3c3c'><font color='{{c:winrate}}'>{{xvm-stat?{{winrate%2d~%|--%}}}}</font> <font color='{{c:wn8}}'>{{xvm-stat?{{wn8%4d|----}}}}</font> {{xvm-stat?{{kb%3d~k|---k}}}} </font><font size='12'>{{vehicle}}</font>",

 

The parts in blue relate to player stats. They are supposed to hide those stats if you disable that function in XVM.

 

Here's how it looks like with stats enabled: screenshot 1

Here's how it looks like with stats disabled: screenshot 2

 

In both screenshots, vehicleFieldShowBorder is enabled. You can see that the yellow rectangles do not move from one screenshot to the next.

However, the text for {{vehicle}} does move, but only for the right side.

In screenshot 2, there appear to be spaces to the left of RightVehicle. I presume that comes from the blue text above. But the effect is different for LeftVehicle.

 

Any ideas why? statisticForm.xc attached.

statisticForm.xc

Share this post


Link to post

Short link
Share on other sites

Any ideas why? statisticForm.xc attached.

"formatLeftVehicle": "<font size='12'>{{vehicle}}</font><font face='mono' size='{{xvm-stat?11|0}}' color='#3c3c3c'> {{kb%3d~k|---k}} <font color='{{c:wn8}}'>{{wn8%4d|----}}</font> <font color='{{c:winrate}}'>{{winrate%2d~%|--%}}</font></font>",
"formatRightVehicle": "<font face='mono' size='{{xvm-stat?11|0}}' color='#3c3c3c'><font color='{{c:winrate}}'>{{winrate%2d~%|--%}}</font> <font color='{{c:wn8}}'>{{wn8%4d|----}}</font> {{kb%3d~k|---k}} </font><font size='12'>{{vehicle}}</font>",
  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

Thanks night_dragon_on, that works.

 

What about hiding the 2 imgs in the nick fields? Using {{xvm-stat?16|0}} in width/height doesn't seem to work.

 

"formatLeftNick": "<img src='xvm://res/icons/flags/{{flag|default}}.png' width='16' height='13'> <img src='xvm://res/icons/xvm/xvm-user-{{xvm-user}}.png'> <font size='12' alpha='#A0'>{{clan}}</font><font size='12'>{{xvm-stat?{{name%.10s~..}}|{{name}}}}</font>",


"formatRightNick": "<font size='12'>{{xvm-stat?{{name%.10s~..}}|{{name}}}}</font><font size='12' alpha='#A0'>{{clan}}</font> <img src='xvm://res/icons/xvm/xvm-user-{{xvm-user}}.png'> <img src='xvm://res/icons/flags/{{flag|default}}.png' width='16' height='13'>",

Share this post


Link to post

Short link
Share on other sites

What about hiding the 2 imgs in the nick fields? Using {{xvm-stat?16|0}} in width/height doesn't seem to work.

 

For a picture just like this:

{{xvm-stat?<img src='xvm://res/icons/flags/{{flag|default}}.png' width='16' height='13'> <img src='xvm://res/icons/xvm/xvm-user-{{xvm-user}}.png'>}}

All the spaces and indents are placed inside the macro {{xvm-stat}}

Edited by night_dragon_on
  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...