Jump to content
Korean Random
spoter

Исходники модов spoter'a на GitHub

Recommended Posts

19.06.2019 в 15:41, spoter сказал:

Над рамкой просто образец записи, оно не функционально.

А вот в рамке, как раз только то что лечится, если в списке нет, то и лечить\чинить не будет.

 

еще вопросик. в вашем моде ВИНТИК, значение "chassis" к колёсной технике относится вообще? я просто не могу проверить, потому как у меня нет колёсной техники.

Edited by Lom

Share this post


Link to post

Short link
Share on other sites

После патча перестало считать отметку, начальное значение правильное, а текущее не считает (т.е. урон и т.д. что идет в отметку, постоянно 0). 

Share this post


Link to post

Short link
Share on other sites
12 минут назад, alex_alex сказал:

После патча перестало считать отметку, начальное значение правильное, а текущее не считает (т.е. урон и т.д. что идет в отметку, постоянно 0). 

какого именно патча?

не считает только первый бой на танке или последующие тоже?

Share this post


Link to post

Short link
Share on other sites

после 1,5,1,0, не считает все бои. 

 

{
    "4939747": {
        "sweden:S21_UDES_03": [ 83.61, 1989, 84.37, 2005, 737235, 737235 ]
    }
}

 

а в бою, где данные для отметки стоит постоянно 0 (раньше не правильно считало отметку первые бои, но там постоянно была цифра урон + ассист)

 

почистил сейчас кэш, все папки мода, перекачал - сейчас еще раз проверю что будет

Нет, не считает. Текущая отметка перекрасилась с фиолетового в красный, но ничего не поменялось.

Share this post


Link to post

Short link
Share on other sites

проведите 3 боя подряд на одном танке, сделайте 2 скриншота для каждого, в начале и в конце боя.

и опубликуйте лечь, будем пытаться разобраться, т.к. вы первый кто на подобное жалуется.

Share this post


Link to post

Short link
Share on other sites

Прекрасно. понял причину.

в настройках клиента отключены счётчики урона\засвета.

вот данные в мод и не попадают.

Включите их плз и проверьте.

Share this post


Link to post

Short link
Share on other sites

Не могу понять какой мод блочит, галочки все стоят. Даже и не заметил, что вгшная эффективность не показывается.

battleObserver убрал и начало считать

shot_007.jpg

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

не совсем понял причины, хотя догадываюсь, не видел код спотера, у меня все к ивентам подключено и включение галочек мне не нужно для сбора данных. нужно чтобы спотер у себя разобрался сперва что не так. :) могу только наводку дать где ивент брать. 

 

feedback = sessionProvider.shared.feedback
if feedback:
    feedback.onPlayerFeedbackReceived += self.__onPlayerFeedbackReceived

Ну и не помешало бы увидеть питон лог.

Edited by Armagomen_dev

Share this post


Link to post

Short link
Share on other sites
3 минуты назад, Armagomen_dev сказал:

не совсем понял причины, хотя догадываюсь, не видел код спотера, у меня все к ивентам подключено и включение галочек мне не нужно для сбора данных. нужно чтобы спотер у себя разобрался сперва что не так. :) могу только наводку дать где ивент брать. 

 


feedback = ServicesLocator.sessionProvider.shared.feedback
if feedback:
    feedback.onPlayerFeedbackReceived += self.__onPlayerFeedbackReceived

 

https://github.com/spoter/spoter-mods/blob/master/mod_marksOnGunExtended/source/mod_marksOnGunExtended.py

 

Share this post


Link to post

Short link
Share on other sites
11 минут назад, spoter сказал:

чтот не совсем понятно зачем ты так далеко залез, попробуй взять из первоисточника :) вот тут смотри :) ну и будет плюсом что ивент работает не зависимо от того стоят ли галочки у юзера.


https://bitbucket.org/Armagomen/battle_observer/src/b0d51509873ebf0ce4dbc91946165677ff81c44f/mod/res/scripts/client/gui/mods/mod_armagomen_battle_observer/battle/DamageLog.py#lines-136

Edited by Armagomen_dev

Share this post


Link to post

Short link
Share on other sites

Добрый вечер. Долго нужно ждать решения. 

З,Ы, раньше эта связка работала (1,5,0 вроде крайний патч)

Share this post


Link to post

Short link
Share on other sites

@spoter посмотрите прошу на mod_mods_gui искал из-за чего вылетает игра после обновления 1602, кажется в нем проблема,

После того как удалил mod_mods_gui клиент норм запустился, но теперь  с Вашими модами беда - не работают... Спасибо.

Share this post


Link to post

Short link
Share on other sites

Ничего не вылетает, проверил.

В логе ошибки есть? Клиент прочекали в лаунчере? Кэш удалили? В папке mods файлов с нулевым размером нет?

  • Upvote 1
  • Downvote 1

Share this post


Link to post

Short link
Share on other sites

@spoter сорян, ошибки есть, сейчас верну и покажу, кеш почистил, клиент чекнул, нулевых нет...

Edited by refaol

Share this post


Link to post

Short link
Share on other sites

@spoter плиз... подскажи как в spotMarks добавлять сектора на картах?

помнится ты про это где то упоминал, почти весь топик перелопатил не нашел((

Share this post


Link to post

Short link
Share on other sites
2 часа назад, DraugDM сказал:

@spoter плиз... подскажи как в spotMarks добавлять сектора на картах?

помнится ты про это где то упоминал, почти весь топик перелопатил не нашел((

О чём речь? какие сектора?

  • Upvote 1
  • Downvote 1

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...