Jump to content
Korean Random
Etlau

XVM 5.0.1-test2 0.8.9

Recommended Posts

 

 

Заментил прикол в этом XVM - иногда, когда вступаешь в бой, накладывается озвучка с ангара.

 

Тоже такое бывает раз в десяток боев. Но не факт что xvm имеет к этому какое-либо отношение.

Share this post


Link to post

Short link
Share on other sites

Скорее баг, чем фича:

 

При "autologin" = "true" в конфиге невозможно запустить риплей, записанный в 0.8.8 из клиента 0.8.9.
 

При выключенном автологине всплывает диалог:

Данная версия WOT не совпадает с версией, для которой записан бой...
Игнорировать разницу в версиях и воспрозвести бой?   [Да] [Нет]

А риплей запускается при нажатии [Да].

 

При включенном автологине этот диалог находится в фоне, над ним висит значок загрузки (логотип WOT с вращающимся катком/шестеренкой).

И кнопку [Да] нажать не получается (она не кликабельна), и автологин не происходит.

 

 

P.S. Есть ли возможность отключить это уведомление (чтоб не нужно было каждый раз подтверждать запуск старого риплея)?

 

 

 

 

 Заментил прикол в этом XVM - иногда, когда вступаешь в бой, накладывается озвучка с ангара.

 

В клиенте часто проскакивают такие приколы со звуковыми событиями (в версии 0.8.8 было то же самое). Больше всего меня раздражает гудящий звук, явно из набора ambient, который звучит (около минуты), если переключиться после "смерти" на другое окно, а затем обратно в окно WOT еще до окончания боя. Я уже и многие файлы внутри банков ambient_*.fsb переслушал. Файлы hangar*, music_main_menu* и music_combat* у меня вообще удалены (запакованы в архивы). Но этот гадостный звук все равно отловить и отключить не получилось.

Edited by Meddio

Share this post


Link to post

Short link
Share on other sites

r2924 nightly - логи питона и xvm и config - вылеты. log.7z

Ещё такой баг: Автологин включен, при старте игры заходит почему-то на RU_3 сервер, вне зависимости от того на каком был в прошлый раз.

Edited by Anix

Share this post


Link to post

Short link
Share on other sites

участились вылеты из клиента после боя ! почти после каждого, ну через раз точно! и это сёдня , вчера, позавчера и т.д. было все Ок!

Share this post


Link to post

Short link
Share on other sites

Скорее баг, чем фича:

При "autologin" = "true" в конфиге невозможно запустить риплей, записанный в 0.8.8 из клиента 0.8.9.

Записал, исправлю.

участились вылеты из клиента после боя ! почти после каждого, ну через раз точно! и это сёдня , вчера, позавчера и т.д. было все Ок!

Хватит писать бесполезные сообщения. Они только мешают.

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

Записал, исправлю.

Большое спасибо! А решение мелкой проблемы с хитлогом случайно не планируется?

Поспешил (или опоздал) с вопросом. В ночной сборке (2925) уже все исправлено. Оба поля HitLog работают корректно. Еще раз спасибо.

 

Автологин включен, при старте игры заходит почему-то на RU_3 сервер, вне зависимости от того на каком был в прошлый раз.

 

Насколько я понимаю, autologin запоминает сервер, который был выбран до включения этой функции (при последнем запуске без autologin).

А потом, даже если ты переключишься на другой сервер (непосредственно из клиента), при закрытии клиента и повторном запуске снова будет выбран упомянутый выше сервер.

 

Если нужно поменять сервер по умолчанию, сделай следующее (мне помогло):

- закрой клиент

- в конфиге отключи autologin

- запусти клиент (выбрав в при запуске нужный тебе сервер)

- закрой клиент

- снова включи autologin в конфиге

- при всех последующих запусках будет использоваться этот сервер

 

Другими словами сервер, который ты выбираешь из выпадающего списка в амбаре, программой не запоминается.

 

У меня тоже при переходе с test1 на test2 (при том, что autologin был включен) всплыл сервер RU3 (которым я никогда не пользовался из-за большого пинга). Видно, он в test2 по умолчанию настроен.

Edited by Meddio

Share this post


Link to post

Short link
Share on other sites

Записал, исправлю.

Хватит писать бесполезные сообщения. Они только мешают.

сорь! просто хотел помочь, чем могу! а вообще-то здесь не только дети, так, что можно и по-уважительнее... послать!

  • Downvote 2

Share this post


Link to post

Short link
Share on other sites
Видно, он в test2 по умолчанию настроен.

Нет, если используете автологин, а в клиенте в поле сервер выбрано значение "Авто", то вас и запустит на оптимальный сервер по меркам WG.

Там учитываеться пинг и количество игроков на сервере. Вобшем перед использованием Автологина желательно вручную в клиенте проставить желаемый сервер для автологина.

Edited by POLIROID

Share this post


Link to post

Short link
Share on other sites

2 POLIROID

 

autologin

Не, у меня всегда сервер вручную выставлен, чаще всего RU5. С ним и проверял свою догадку. Значение "Авто" никогда не выбираю.

 

Пример:

 

- autologin выключен

- запускаем клиент, выбираем RU1, после полной загрузки игры закрываем клиент

- включаем autologin

- запускаем клиент, он автоматом подключается к RU1

- в ангаре выбираем из выпадающего списка RU5

- клиент перезапускаетсся, подключившись к RU5

- закрываем клиент

- снова открываем - и он подключается к RU1 (а не к RU5)

 

А переподключило на RU3 действительно без моего участия. Я его точно вручную не выбирал. Да и сам клиент, даже если б у меня было бы выбрано Авто, к нему не подключился бы, т.к. пинг на RU5 - 25, а на RU3 - 52.

Share this post


Link to post

Short link
Share on other sites

а у меня помимо прочего есть еще и такая проблемка:

сразу после начала боя иногда пропадает одна из баз с миникарты! любая из трех (союзная, вражеская или нейтральная). появилось это еще с 0.8.8.

 

и по поводу озвучки тоже скажу - при загрузке боя иногда бывает начинается мелодия карты и тут же замолкает! и тишина до начала боя. потом все нормально.

 

п.с. стоят моды Джова, озвучка Катюша и сразу после 0.8.9 поверх Джова обновлял XWM до 5.0.1-test2

Share this post


Link to post

Short link
Share on other sites

2 POLIROID

 

autologin

Не, у меня всегда сервер вручную выставлен, чаще всего RU5. С ним и проверял свою догадку. Значение "Авто" никогда не выбираю.

 

Пример:

 

- autologin выключен

- запускаем клиент, выбираем RU1, после полной загрузки игры закрываем клиент

- включаем autologin

- запускаем клиент, он автоматом подключается к RU1

- в ангаре выбираем из выпадающего списка RU5

- клиент перезапускаетсся, подключившись к RU5

- закрываем клиент

- снова открываем - и он подключается к RU1 (а не к RU5)

 

А переподключило на RU3 действительно без моего участия. Я его точно вручную не выбирал. Да и сам клиент, даже если б у меня было бы выбрано Авто, к нему не подключился бы, т.к. пинг на RU5 - 25, а на RU3 - 52.

Делайте смену сервера не из ангара, а через отключение и повторное подключение.

Share this post


Link to post

Short link
Share on other sites

 

...,кроме в окне достижений всё время при открытии показывает 1-ю вкладку.(игнорирует прописанную в конфиге 4-ю)

 

7nRno2v.jpg

 

 

Такая же ботва((

Как вылечить, кто знает?

Share this post


Link to post

Short link
Share on other sites

сорь! просто хотел помочь, чем могу! а вообще-то здесь не только дети, так, что можно и по-уважительнее... послать!

 

Куда уж уважительнее посылать? Или он должен был рассыпатся в извинениях?

Share this post


Link to post

Short link
Share on other sites

При отключенной стате вылетов нет!

Как только включаешь статистику 2-3 боя - вылет на рабочий стол!!!


Такая же ботва((

Как вылечить, кто знает?

+1

Edited by ODIS

Share this post


Link to post

Short link
Share on other sites

На ночной сборке 2925 за два дня ни одного вылета. Все работает безупречно. Статистика включена.

 

http://download-xvm.by-reservation.com:8080/xvm/

 

До этого на test1 и test2 было в среднем по 1 вылету на 10 боев.

Edited by Meddio

Share this post


Link to post

Short link
Share on other sites

Скорее баг, чем фича:

При "autologin" = "true" в конфиге невозможно запустить риплей, записанный в 0.8.8 из клиента 0.8.9.

Исправил

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

На ночной сборке 2925 за два дня ни одного вылета. Все работает безупречно. Статистика включена.

 

http://download-xvm.by-reservation.com:8080/xvm/

 

До этого на test1 и test2 было в среднем по 1 вылету на 10 боев.

Добрый день. Вы говорите статистика включена, о какой статистике идет речь? Если можно скрин приложите.......

Edited by Uazikk

Share this post


Link to post

Short link
Share on other sites

Добрый день. Вы говорите статистика включена, о какой статистике идет речь? Если можно скрин приложите.......

 

Нужно было еще три раза по дереву постучать (=

После того поста был один вылет.

 

А под включеннной статистикой я имею в виду, что:

- в rating.xc: showPlayersStatistics = true

- а в battleLoading.xc, markersAliveExtended.xc, playersPanel.xc и statisticForm.xc

используются макросы {{wn}}, {{xwn}}, {{eff}} либо {{xeff}} (и макросы соответсвующих цветов {{c: ... } )

(как раз на этих днях тестировал разные виды рейтинга и выбирал наиболее удобный - при этом все четыре работают корректно)

 

// wn - рейтинг WN6, eff - рейтинг эффективности WOT-NEWS, xwn и xeff - те же показатели, приведенные к единой шкале XVN

Edited by Meddio

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...