Jump to content
Korean Random
Mr 13

"Ночные версии" XVM / Nightly Builds

Recommended Posts

Бывает что "рисованные" символы вылазят за рамки клетки которая ограничивает символ, тогда он либо инвертирует цвета,как у тебя,либо срезает.  

в MS Word или т.п.- да, срезает строками, которые выше и ниже, а в игре- пофиг, тут нет никаких строк, поэтому даже если символ выходит за пределы ячейки рисует целиком. К тому же низ в зону символа как раз вписывается, не вписывается верх, а с ним проблем нет. Тут какая-то хитрая попа, не все так просто

post-6084-0-12117900-1381994179_thumb.jpg

Я конечно попробую поиграться, вогнать символ в рамки, поглядим, чего из этого выйдет, но до сих пор это не имело значения. В любом случае, спасибо за участие:)

Edited by demon2597

Share this post


Link to post

Short link
Share on other sites

но до сих пор это не имело значения.

Может WG что-то в движке сменили.

Share this post


Link to post

Short link
Share on other sites

 

 

символы вылазят за рамки клетки которая ограничивает символ, тогда он либо инвертирует цвета,как у тебя,либо срезает

 

Я конечно попробую поиграться, вогнать символ в рамки, поглядим, чего из этого выйдет, но до сих пор это не имело значения

 

Может WG что-то в движке сменили.
Видимо действительно чего-то изменилось. Вогнал символ в вертикальные пределы- стало как положено. Причем косяк только если символ сильно не вписывается по вертикали, если немного- не влияет.

Share this post


Link to post

Short link
Share on other sites

Видимо действительно чего-то изменилось. Вогнал символ в вертикальные пределы- стало как положено. Причем косяк только если символ сильно не вписывается по вертикали, если немного- не влияет.

Вот и славно, "Одна голова хорошо а две лучше" :) Гавное что бы WG таких "подарочков" поменьше делали.

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

 

 

Вогнал символ в вертикальные пределы- стало как положено.

ждем обновления шрифта.

Share this post


Link to post

Short link
Share on other sites

ждем обновления шрифта.

Всё, как обычно, под обновление XVM

Share this post


Link to post

Short link
Share on other sites

последние несколько билдов ночника, которые ставил, вроде начиная с 283х и 2849 включительно при захвате базы начинает рисовать на экране странные артефакты(четырехугольники в верхней половине экрана разных цветов), если захват пропадает, то и они тоже пропадают.

Share this post


Link to post

Short link
Share on other sites

(четырехугольники в верхней половине экрана разных цветов)

скрин, что ль?

Edited by leecher88

Share this post


Link to post

Short link
Share on other sites

исправьте баг, когда я создаю роту и набираю бойцов, если часто открывать статистику игроков, то она начинает долго открываться, и не откроется пока я не нажму показать статистику какого нибуть другого игрока, и тогда передо мной, 2 окна статистики))) и иногда пишет статистика этого игрока не доступна.

Share this post


Link to post

Short link
Share on other sites

@Demishn, шрифтов не хватает.

Влюбом случае, у меня все нормально.

Edited by NikolayHAOS

Share this post


Link to post

Short link
Share on other sites

в 0.8.9 test2 было добавлено:

В окне достижений добавлен специальный раздел статистики командных боёв.

9c69da3ad60e3976e6c0b2ef20209148.jpg

При установки xvm build 2851 при нажатии Достижения игра сразу же вылетает. Если удалить файл Application.swf то игра не вылетает в Достижениях

Share this post


Link to post

Short link
Share on other sites

в 0.8.9 test2 было добавлено:

В окне достижений добавлен специальный раздел статистики командных боёв.

 

При установки xvm build 2851 при нажатии Достижения игра сразу же вылетает. Если удалить файл Application.swf то игра не вылетает в Достижениях

в 2853 вроде пофиксили

Share this post


Link to post

Short link
Share on other sites

Столкнулся со странной проблемой. 

Есть конфиг, на котором играю на 088 с test5, закидываю его на 089 build 2853 после загрузки боя нет не одного маркера над танком, не одной надписи не у союзников, не у противников

0162cae8897eaef24cba0623df42c109.jpg

при чем засветившись противник на миникарте есть а увидеть его без маркера крайне сложно в реалиях боя. Но при попадании по кому то в момент вывода дамага появляются все маркера над всеми танками, но вскоре опять пропадают, а вот после серии с 5-7 пробитий, тогда уже маркера не пропадают и можно уже играть видя противника.

в логе ошибок по конфигу не пишет, видимо из-за этого дефолтный не подгружает.  

 

python.log

xvm.log

Share this post


Link to post

Short link
Share on other sites

Столкнулся со странной проблемой. 

Есть конфиг, на котором играю на 088 с test5, закидываю его на 089 build 2853 после загрузки боя нет не одного маркера над танком, не одной надписи не у союзников, не у противников

 

при чем засветившись противник на миникарте есть а увидеть его без маркера крайне сложно в реалиях боя. Но при попадании по кому то в момент вывода дамага появляются все маркера над всеми танками, но вскоре опять пропадают, а вот после серии с 5-7 пробитий, тогда уже маркера не пропадают и можно уже играть видя противника.

в логе ошибок по конфигу не пишет, видимо из-за этого дефолтный не подгружает.  

 

Сразу вопрос: - А с xvm089 вы играете на клиенте 088 или на тесте?

Share this post


Link to post

Short link
Share on other sites

А с xvm089 вы играете на клиенте 088 или на тесте?

В python.log видно, что клиент 0.8.9 СТ3.

 

Оффтоп:

уже 3-тест, а ошибку

[ERROR] (scripts/client/helpers/EffectsList.py, 620): Failed to find parameter named 'mode' in sound event named '/objects/fire/house_burn_light'

WG никак не поправит...

Share this post


Link to post

Short link
Share on other sites

продолжение со странной проблемой о писаной в посте #334

заменил в своем конфиге блок макреков на дефолт, все работает, но как только в дефолтном изменяю положение значка типа танка и переношу его выше ("y": -65,), маркера пропадают по схеме как было описано в посте #334 причем заменил только в обычном, а расширенный не трогал, потому при альте показывает все как надо, а в простом режиме пропадает пока не будет от рисовки дамага.

Вопрос как это поправить, ведь привык уже к своему конфигу с расположением значка типа танка сверху

может WG размер области блока над танком изменили?

 

Share this post


Link to post

Short link
Share on other sites

продолжение со странной проблемой о писаной в посте #334

заменил в своем конфиге блок макреков на дефолт, все работает, но как только в дефолтном изменяю положение значка типа танка и переношу его выше ("y": -65,), маркера пропадают по схеме как было описано в посте #334 причем заменил только в обычном, а расширенный не трогал, потому при альте показывает все как надо, а в простом режиме пропадает пока не будет от рисовки дамага.

Вопрос как это поправить, ведь привык уже к своему конфигу с расположением значка типа танка сверху

может WG размер области блока над танком изменили?

да, есть такое. что-то поменялось, надо смотреть что именно. VMM.swf тот же, так что что-то в питоне, по-видимому.

после загрузки боя нет не одного маркера над танком, не одной надписи не у союзников, не у противников

появилось в 0.8.9.CT3, или так же было на 0.8.9.CT2? Я поставил y=-35, при этом маркеров сначала нет, потом они появляются, и если покрутить камерой, то они то появляются, то исчезают. Если в снайперском режиме приблизить-удалить, тоже - то появляются, то исчезают. Вот, пытаюсь найти после какого момента это стало появляться.

Share this post


Link to post

Short link
Share on other sites

на первом тесте не играл, на втором такое было уже.

да, тоже заметил, что если крутить вокруг танка камеру то есть места где появляются маркера правда такое наблюдал уже после смерти в режиме наблюдателя на союзнике

так же загадка, почему после серии где то с 5-7 пробитий, когда всплывающий урон выводится маркера потом не пропадают

Edited by booch_124

Share this post


Link to post

Short link
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...