Jump to content
Korean Random
Mixaill

[FIXED] DO NOT LAUNCH GAME USING WGC / НЕ ЗАПУСКАЙТЕ ИГРУ ЧЕРЕЗ WGC

Recommended Posts

Fixed. Restart WGC to apply update.

Исправлено перезапустите WGC для обновления.

-------

 

After today's update, don't run the game via WGC. This will lead to incorrect loading of mods.

To start the game, run Worldoftanks.exe or win32/worldoftanks.exe directly from the game directory.

 

После сегодняшнего апдейта, не запускайте игру через WGC. Это приведет к некорректной загрузке модов.

Для запуска, напрямую запустите Worldoftanks.exe или win32/worldoftanks.exe из каталога игра.

 

-------

 

Это связано с тем, что клиент игры реагирует на переданный рабочий каталог, в котором располагается исполняемый файл клиента (/win32 или /win64 для 1.6.1). 

 

WGC переопределяет Working Directory в [WOT_DIR]. В результате, при запуске из WGC, рабочий каталог смотрит в [WORK_DIR], в то время как при прямом запуске он равен [WOT_DIR]/Win32. По итогу, всё идёт не совсем по плану.

 

Надеемся на скорое исправление с возвращением старого поведения WGC.

Edited by Mixaill
  • Upvote 7

Share this post


Link to post

Short link
Share on other sites

похоже кто-то в очередной раз обкакался и пора подгузник менять :)

 

пс минусы ставят сотрудники которые обкакались :) хД

Edited by Armagomen_dev
  • Upvote 5
  • Downvote 4

Share this post


Link to post

Short link
Share on other sites

Fixed with the WGC configuration update. Restart WGC to apply it.

Исправлено на стороне WGC модификацией конфига. Перезапустите WGC для принятия изменений.

Edited by Mixaill

Share this post


Link to post

Short link
Share on other sites

То есть, я правильно понял, что было сделано исправление, возвращавшее старое поведение (и пути к конфигам), но, поскольку все уже переехали на новую систему, это исправление пришлось откатывать?

Share this post


Link to post

Short link
Share on other sites

Ждем:

Небольшое обновление для версии 1.6.1

10 октября в 21:00 (МСК) выйдет срочное небольшое обновление, которое исправит некоторые технические ошибки.
Остановка сервера не планируется, обновление установится автоматически после перезапуска игры.

Share this post


Link to post

Short link
Share on other sites

Ефать-копать, а я тут вчера узнал что старый лаунчер робит, и опять пересел на него. Так что WGC идёт мимо )))))

Share this post


Link to post

Short link
Share on other sites

У меня вообще не загружается ночник, ни вчерашний 102, ни сегодняшний 107. Игра запускается, но xvm вообще никак себя не проявляет. Причем по разному запускать пробовал - и через wgc, и из папок win32, win64 и из корня игры. Это известная проблема или отдельный репорт запилить?

python.log

Edited by Red_Noise

Share this post


Link to post

Short link
Share on other sites
17 минут назад, Red_Noise сказал:

У меня вообще не загружается ночник, ни вчерашний 102, ни сегодняшний 107. Причем по разному запускать пробовал - и через wgc, и из папок win32, win64 и из корня игры. Это известная проблема или отдельный репорт запилить?

python.log 247 kB · 2 скачивания

темой промахнулись...

Edited by Armagomen_dev

Share this post


Link to post

Short link
Share on other sites
35 минут назад, Polyacov_Yury сказал:

То есть, я правильно понял, что было сделано исправление, возвращавшее старое поведение (и пути к конфигам), но, поскольку все уже переехали на новую систему, это исправление пришлось откатывать?

Неа, все изменения были на стороне WGC

 

В начале патча было

Запускаем: [WoT]/worldoftanks.exe

Рабочий каталог: [WoT]

 

Днём решили форсировать 32-бита, но забыли поменять рабочий каталог, по итогу:

 

Запускаем: [WoT]/win32/worldoftanks.exe

Рабочий каталог: [WoT]

 

Из-за этого моды начали смотреть в [WoT]/../res_mods

 

Вечером рабочий каталог поправили и всё вернулось в норму:

Запускаем: [WoT]/win32/worldoftanks.exe

Рабочий каталог: [WoT]/win32

Share this post


Link to post

Short link
Share on other sites

@Red_Noise , ознакомьтесь с правилами раздела.

  • удостовериться, что проблема отсутствует в чистом клиенте и проявляется только с новейшей ночной сборкой XVM (использование других модификаций для тестирования недопустимо)

Логи при наличие других модификаций помимо XVM не принимаются.

И тема не подходящая.

Share this post


Link to post

Short link
Share on other sites
2 минуты назад, Mixaill сказал:

Неа, все изменения были на стороне WGC

 

В начале патча было

Запускаем: [WoT]/worldoftanks.exe

Рабочий каталог: [WoT]

 

Днём решили форсировать 32-бита, но забыли поменять рабочий каталог, по итогу:

 

Запускаем: [WoT]/win32/worldoftanks.exe

Рабочий каталог: [WoT]

 

Из-за этого моды начали смотреть в [WoT]/../res_mods

 

Вечером рабочий каталог поправили и всё вернулось в норму:

Запускаем: [WoT]/win32/worldoftanks.exe

Рабочий каталог: [WoT]/win32

вот бы еще с питон логом разобрались, если есть связь дайте им знать что 2 отдельных это плохо, они потом у юзера нужного не допросятся, поскольку не известно какая у него версия запустится когда 64 включат.

Edited by Armagomen_dev

Share this post


Link to post

Short link
Share on other sites
2 минуты назад, night_dragon_on сказал:

@Red_Noise , ознакомьтесь с правилами раздела.

  • удостовериться, что проблема отсутствует в чистом клиенте и проявляется только с новейшей ночной сборкой XVM (использование других модификаций для тестирования недопустимо)

ну как отсутсвует, а если проблема это и есть то что по сути чистый клиент и запускается, как будто нет никакого xvm)

Share this post


Link to post

Short link
Share on other sites

@Red_Noise , не нужно читать между строк, вам выделили цветом конкретный пункт правил который вы не удосужились соблюсти при публикации сообщения в данном разделе форума.

 

9 минут назад, Red_Noise сказал:

У меня вообще не загружается ночник

  1. Очистите директории для модификаций (mods и res_mods)
  2. Проверьте целостность клиента в лаунчере или WGC
  3. Установите только XVM.

И только в этом случае, прикрепляйте отчет и/или логи в данном разделе.

И никак иначе.

 

10 минут назад, Red_Noise сказал:

Причем по разному запускать пробовал - и из папок win64

 

XVM не поддерживает 64-разрядную версию клиента.

Share this post


Link to post

Short link
Share on other sites
13 минут назад, night_dragon_on сказал:

@Red_Noise , не нужно читать между строк, вам выделили цветом конкретный пункт правил который вы не удосужились соблюсти при публикации сообщения в данном разделе форума.

 

  1. Очистите директории для модификаций (mods и res_mods)
  2. Проверьте целостность клиента в лаунчере или WGC
  3. Установите только XVM.

И только в этом случае, прикрепляйте отчет и/или логи в данном разделе.

И никак иначе.

 

 

XVM не поддерживает 64-разрядную версию клиента.

сделал отдельную тему.

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...