Jump to content
Korean Random
Sign in to follow this  
Grumm

Постоянные пропуски кадров из-за задержек кодирования

Recommended Posts

Народ, столкнулся с такой проблемой которую не могу решить уже несколько дней, суть вот в чём

Скачиваю и настраиваю OBS, кодировщик x264, битрейт 3200, приоритет процессора почти максимальный, профиль main,  управление битрейтом CBR, пользовательский буфер 10000, картинка 1440 на 900 в 50 кадров,Запускаю трансляцию. Всё идет, пропущенных кадров максимум 2 процента ( иногда процессор из-за игры и трансляции одновременно не справляется и бывают тормоза). Всё идёт прекрасно на протяжении всей трансляции, вот я уже прощаюсь и выключаю его. на следующий день опять врубаю трансляцию и вижу что 98-100 процентов пропущенных кадров из-за задержек кодирования, при том что процессор нагружен максимум на 50 процентов , хотя игра та же и настройки трансляции те же. я пытался изменять настройки как и игры так и трансляции - толку ноль. После чего мне надоело и я переустановил OBS настроил как было до этого и чудо трансляция идёт нормально, но на следующие сутки ровно тоже самое, я делал так несколько раз и мне надоело. У меня нету желания постоянно удалять и скачивать OBS, в чём может быть проблема?

Моя система: Процессор: Xeon e5 1650v2

                        Оперативная память: 2 планки по 8 гигабайт DDR3 (1333 Mhz)

                        Видеокарта: 1050 ti 

                        Материнская плата: Huanan x79 v2.49PB

                        Система как и OBS и другой софт стоит на SSD 240gb

Share this post


Link to post

Short link
Share on other sites

@Grumm , попробуй этот совет.

 

1 час назад, Grumm сказал:

пропущенных кадров максимум 2 процента ( иногда процессор из-за игры и трансляции одновременно не справляется и бывают тормоза)

 

Раз у вас при полной нагрузке на процессор (игра + стрим) пропуск кадров составляет всего лишь 2 процента, то эта проблема:

 

1 час назад, Grumm сказал:

врубаю трансляцию и вижу что 98-100 процентов пропущенных кадров

 

Врятли из-за "задержек кодирования" при общей нагрузке порядка 50 процентов.

Тут скорее всего проблемы с сетевым подключением наблюдаются.

Из-за проблем с подключением к серверу/низкой скоростью отдачи наблюдаются пропуски кадров.

 

Если стримишь на твич, то желательно вручную выбрать наилучший сервер (а не довольствоваться автоматическим выбором) с помощью утилиты TwitchTest. Если же стримишь на ютуб, то можно попробовать стримить на backup сервер (или как он там правильно называется, в общем резервный).

Share this post


Link to post

Short link
Share on other sites
43 минуты назад, evgen.martynov сказал:

Тут скорее всего проблемы с сетевым подключением наблюдаются.

 Всё так как вы написали, трансляция тупит из-за интернета, я выбрал ближайшей сервер с минимально задержкой, но проблема не исчезла. Всё те же пропущенные кадры, только в этот раз половина кадров выпала из-за интерната. И при переустановки проблема исчезает, но на следующий день опять та же проблема. 

Я тут запускал трансляцию с разными настройками, и ставил автонастройку и вот результат: Если использовать NVENC то всё идет без пропущенных кадров вообще, картинка достаточно нормальная, НО он сам по себе может зависнуть на секунд 15-30 твич его просто не грузит и это происходит достаточно часто(и да я транслирую на твич) а если ставлю автонастройку и ничего не меняю кроме кодека на x264 то кадры по прежнему выпадают до 100 процентов при том что выбран ближайший сервер, и да интернет у меня 100 м/бит потому он должен работать вообще без тормозов, а мне нужно транслировать через процессор но ничего не помогает, есть ещё есть варианты почему он так тупит?

(скриншот - трансляция через процессор со автонастройкой)

image.png

Share this post


Link to post

Short link
Share on other sites

@Grumm ну судя по вот этому

image.png.9d45124eaf424c8d5107a9c4326b7753.png

кадры теряются из-за хренового подключения. А то что они ещё и из-за задержки кодирования теряются возможно уже побочный эффект такой большой потери от интернета.

Уверен что проблема пропадает именно после переустановки, а не просто потому что тест с переустановкой например проходит в другое время, когда у провайдера уже нагрузка ниже? )


И буфер пробовал отключать?

Share this post


Link to post

Short link
Share on other sites
13 часов назад, yepev сказал:

Уверен что проблема пропадает именно после переустановки, а не просто потому что тест с переустановкой например проходит в другое время, когда у провайдера уже нагрузка ниже? )


И буфер пробовал отключать?

была на выходных трансляция, часов 12-14 не помню с 9 утра до ночи и всё было нормально (после переустановки) буфер включал, выключал, ставил больше меньше не помогает, потому не думаю что проблема в провайдере

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×