Jump to content
Korean Random
GafGaf

Постоянные вылеты

Recommended Posts

Всем привет. Ребят, нужна помощь в поиске причины вылета. Сам в этом не шарю, к сожалению, вижу только ошибки по gui/Scaleform. Можно ли с этим справится?

crashdump.dmp

crashrpt.xml

python.log

xvm.log

Share this post


Link to post

Short link
Share on other sites

Что-то я не понимаю:

Traceback (most recent call last):
  File "scripts/common/Event.py", line 44, in __call__
  File "C:/World_of_Tanks/res_mods/1.1.0.1/scripts/client\gui\mods/mod_spot_indicator.py", line 74, in myPe_onArenaPeriodChange
AttributeError: 'PlayerAvatar' object has no attribute 'playerVehicleID'

 

Share this post


Link to post

Short link
Share on other sites
18 минут назад, ktulho сказал:

World_of_Tanks/res_mods/1.1.0.1/scripts/

:veryhappy:

Share this post


Link to post

Short link
Share on other sites

Я на это сперва и внимание на обратил.. Не знаю на какой файл он ссылается, у меня на С только система. Игра стоит на другом диске (физически).

Что это за ересь? :wacko:

Share this post


Link to post

Short link
Share on other sites
1 час назад, ktulho сказал:

1.1.0.1

встречал такое у пары юзеров, даже похлеще. надо переустанавливать клиент.

Share this post


Link to post

Short link
Share on other sites
19 минут назад, Pavel3333 сказал:

встречал такое у пары юзеров, даже похлеще. надо переустанавливать клиент.

Паша с твоим модом та же ересь, я его кинул не глядя, мод работает.

Но он лежит в папке 1.4.0.0!

Share this post


Link to post

Short link
Share on other sites
37 минут назад, Pavel3333 сказал:

встречал такое у пары юзеров, даже похлеще. надо переустанавливать клиент.

В том-то и вся соль.. Прежде чем сюда написать я попробовал всё. Переустанавливал игру, винду, не знаю зачем, но и менял расположение игры по дискам, разные моды пробовал - всё сводится к крашам. Можно конечно и без модов играть, но я уже слишком привык :unsure:

Share this post


Link to post

Short link
Share on other sites
1 час назад, Scharfhobel сказал:

Паша с твоим модом та же ересь, я его кинул не глядя, мод работает.

Но он лежит в папке 1.4.0.0!

Это не ересь, это подгрузка через XFW. Мои моды лежат в res_mods/mods/xfw_packages/ . А подгрузятся они или нет - зависит от наличия XFW (или XVM). Пакет XFW идет в архивах с моими модами.

Edited by Pavel3333

Share this post


Link to post

Short link
Share on other sites
5 часов назад, GafGaf сказал:

..Не знаю на какой файл он ссылается, у меня на С только система. Игра стоит на другом диске (физически).

Что это за ересь? :wacko:

это не ересь, это результат установки мода через инсталлятор, в котором либо вшит путь установки,  либо ты пропустил окно, где можно указать путь к клиенту

 

3 часа назад, GafGaf сказал:

В том-то и вся соль.. Прежде чем сюда написать я попробовал всё. Переустанавливал игру, винду, не знаю зачем, но и менял расположение игры по дискам, разные моды пробовал - всё сводится к крашам. Можно конечно и без модов играть, но я уже слишком привык :unsure:

винда....радикальный подход, зато новенькая (какая ?)

игра.... через  гейм центр  или  старый  инсталлятор   ( у части народа, через гейм,  даже чистый клиент ложится)

моды... конфликт между модами, как и необновлённые, тоже вроде никто не отменял

---

начни с простого

Traceback (most recent call last):
  File "scripts/common/Event.py", line 44, in __call__
  File "C:/World_of_Tanks/res_mods/1.1.0.1/scripts/client\gui\mods/mod_spot_indicator.py", line 74, in myPe_onArenaPeriodChange
AttributeError: 'PlayerAvatar' object has no attribute 'playerVehicleID'

найди  C:/World_of_Tanks/res_mods/1.1.0.1/scripts/

зайди в установку и удаление программ, найди инсталятор и удали мод...на крайний случай, снеси ручками  C:/World_of_Tanks/

---

а так же, можешь попробовать вручную снести мод

D:/games/world_of_tanks/mods/1.4.0.1/spot_indicator.wotmod

-----

в корне игры на диске D,  удали логи, запусти клиент, выключи клиент, логи в студию

Edited by tricsi

Share this post


Link to post

Short link
Share on other sites

@tricsi @tricsi 

Винда 10 pro 10.0.17134 (лицуха)

По диску С - нет такой папки, в PF тоже нет.

Первый по времени запуск на чистом клиенте, потом с модами джованни.

python.log

xvm.log

222.jpg

Share this post


Link to post

Short link
Share on other sites
19 hours ago, GafGaf said:

Я на это сперва и внимание на обратил.. Не знаю на какой файл он ссылается, у меня на С только система. Игра стоит на другом диске (физически).

Что это за ересь?

Всё нормально. Просто мод под защитой, путь забинден при его сборке. Так бывает.

Share this post


Link to post

Short link
Share on other sites
6 минут назад, GafGaf сказал:

@tricsi @tricsi 

Винда 10 pro 10.0.17134 (лицуха)

По диску С - нет такой папки, в PF тоже нет.

Первый по времени запуск на чистом клиенте, потом с модами джованни.

python.log

xvm.log

222.jpg

Игра вылетает с модами от джовани? В логах ничего нет.

Share this post


Link to post

Short link
Share on other sites
25 минут назад, Scharfhobel сказал:

Игра вылетает с модами от джовани? В логах ничего нет.

Да, с ними. В этих логах быть ничего и не могло - попросили просто зайти и выйти. Вот логи обновлённые, первый же бой - краш

xvm.log

python.log

Share this post


Link to post

Short link
Share on other sites
47 минут назад, GafGaf сказал:

Да, с ними. В этих логах быть ничего и не могло - попросили просто зайти и выйти. Вот логи обновлённые, первый же бой - краш

xvm.log

python.log

Переименуй папки res_mods в res_mods++ и mods в mods++ , либо удали их и установи базовый модрак от протанки.

Просто я с ним играю и у меня всё нормально. И логи можно будет сравнить.

 

Edited by Scharfhobel

Share this post


Link to post

Short link
Share on other sites
16 минут назад, Scharfhobel сказал:

Переименуй папки res_mods в res_mods++ и mods в mods++ , либо удали их и установи базовый модрак от протанки.

Просто я с ним играю и у меня всё нормально. И логи можно будет сравнить.

 

Сейчас сделаю. А протанки у меня до этого стояли и от соло пробовал ставить, результат один и тот же

upd сейчас с переименованными папками клиент не запускается :smile:

Edited by GafGaf

Share this post


Link to post

Short link
Share on other sites
7 минут назад, GafGaf сказал:

Сейчас сделаю. А протанки у меня до этого стояли и от соло пробовал ставить, результат один и тот же

upd сейчас с переименованными папками клиент не запускается :smile:

Нужно поставить протанки затем запускать.

Share this post


Link to post

Short link
Share on other sites
2 минуты назад, Scharfhobel сказал:

Нужно поставить протанки затем запускать.

Всё, допёрло что ты имел ввиду, попробую

55 минут назад, Scharfhobel сказал:

Переименуй папки res_mods в res_mods++ и mods в mods++ , либо удали их и установи базовый модрак от протанки.

Просто я с ним играю и у меня всё нормально. И логи можно будет сравнить.

 

Тоже самое.. я хз уже что делать

python.log

xvm.log

Share this post


Link to post

Short link
Share on other sites
47 минут назад, GafGaf сказал:

Всё, допёрло что ты имел ввиду, попробую

Тоже самое.. я хз уже что делать

python.log

xvm.log

А игру на целостность проверял?  Проверь.

Странная ошибка.  Как сказал народ: удалить всё и поставить SD клиент.

 

Share this post


Link to post

Short link
Share on other sites
37 минут назад, Scharfhobel сказал:

А игру на целостность проверял?  Проверь.

Странная ошибка.  Как сказал народ: удалить всё и поставить SD клиент.

 

Да, конечно проверял

Share this post


Link to post

Short link
Share on other sites

@GafGaf 

не внимателен батенька...

ручками удалить

spot_indicator.wotmod

----

а гейм центр так и стоит ?

Edited by tricsi

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...