Jump to content
Korean Random
Pavel3333

[1.9.0.3] Мод Позиций v2.0

Recommended Posts

@Pavel3333 с последним ночником завелся тока на 32 бита.

А этот модуль com.modxvm.xfw.native может тебе стоит в папку с твоим модом ложить, чтоб не путался?

Share this post


Link to post

Short link
Share on other sites

@Scharfhobel вотмод ложить в папку с модом?

обновлено для 1.9.0.3

Share this post


Link to post

Short link
Share on other sites
3 часа назад, Pavel3333 сказал:

@Scharfhobel вотмод ложить в папку с модом?

обновлено для 1.9.0.3

не завелось на 64 битах и хвм отвалился.

Цитата

2020-05-15 17:48:47.354: INFO: [root] [XFW/Loader] Loading mod: com.modxvm.xfw.native, v. 2.0.1
2020-05-15 17:48:52.876: ERROR: [root] [XFW/Native] Error on loading native module 'python27.dll' from package 'com.modxvm.xfw.native'
Traceback (most recent call last):
  File "./src/wot_python/__init__.py", line 74, in load_native
SystemError: dynamic module not initialized properly

2020-05-15 17:48:52.877: ERROR: [root] [XFW/Native] [init] Failed to load python27
2020-05-15 17:48:52.877: ERROR: [root] [XFW/Loader] Loading mod: 'com.modxvm.xfw.native' FAILED (flag)
2020-05-15 17:48:52.877: WARNING: [root] [XFW/Loader] Error with mod: 'com.pavel3333.mods.PositionsMod'. Feature failed: 'native' in package 'com.modxvm.xfw.native'
2020-05-15 17:48:52.877: WARNING: [root] [XFW/Loader] Error with mod: 'com.modxvm.xfw.wotfix.hidpi'. Feature failed: 'native' in package 'com.modxvm.xfw.native'
2020-05-15 17:48:52.877: INFO: [root] [XFW/Loader] Loading mod: com.modxvm.xfw.libraries, v. 8.5.3.0002
2020-05-15 17:48:52.877: WARNING: [root] [XFW/Loader] Error with mod: 'com.modxvm.xfw.wotfix.crashes'. Feature failed: 'native' in package 'com.modxvm.xfw.native'
2020-05-15 17:48:52.877: WARNING: [root] [XFW/Loader] Error with mod: 'com.modxvm.xfw.mutex'. Feature failed: 'native' in package 'com.modxvm.xfw.native'
2020-05-15 17:48:52.877: WARNING: [root] [XFW/Loader] Error with mod: 'com.modxvm.xfw.filewatcher'. Feature failed: 'native' in package 'com.modxvm.xfw.native'
2020-05-15 17:48:52.877: WARNING: [root] [XFW/Loader] Error with mod: 'com.modxvm.xfw.ping'. Feature failed: 'native' in package 'com.modxvm.xfw.native'
2020-05-15 17:48:52.877: INFO: [root] [XFW/Loader] Loading mod: com.modxvm.xfw.actionscript, v. 8.5.3.0002
2020-05-15 17:48:52.895: WARNING: [root] [XFW/Loader] Error with mod: 'com.modxvm.xfw.wwise'. Feature failed: 'native' in package 'com.modxvm.xfw.native'
2020-05-15 17:48:52.895: WARNING: [root] [XFW/Loader] Error with mod: 'com.modxvm.xfw.fonts'. Feature failed: 'native' in package 'com.modxvm.xfw.native'
2020-05-15 17:48:52.896: INFO: [root] [XFW/Loader] Loading mod: com.modxvm.xvm, v. 8.5.3.0002
2020-05-15 17:48:52.960: ERROR: [root] [XFW/Loader] Loading mod: 'com.modxvm.xvm' FAILED (exception)
Traceback (most recent call last):
  File "./__init__.py", line 454, in mods_load
  File "scripts/common/Lib/importlib/__init__.py", line 37, in import_module
  File "res_mods/mods/xfw_packages\xvm_main\python\__init__.py", line 53, in <module>
    import config
  File "res_mods/mods/xfw_packages\xvm_main\python\config.py", line 45, in <module>
    import userprefs
  File "res_mods/mods/xfw_packages\xvm_main\python\userprefs.py", line 27, in <module>
    from fs.osfs import OSFS
  File "./fs/osfs/__init__.py", line 32, in <module>
  File "./fs/osfs/watch.py", line 23, in <module>
  File "./fs/osfs/watch_win32.py", line 16, in <module>
  File "C:\repos\xfw.native\src\cpython_python\ctypes\__init__.py", line 7, in <module>
AttributeError: mro

 

Share this post


Link to post

Short link
Share on other sites

@Scharfhobel обнова уже в пути

обновил native, должен прогружаться

 

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

А на сайте ссылка для скачивания, это для 64 или для 32-бит версия? У меня работает только на 32-битной версии. При запуске на 64-битной версии не работает, еще и у XVM шрифты ломает.

Share this post


Link to post

Short link
Share on other sites
21 минуту назад, gizmojaf сказал:

А на сайте ссылка для скачивания, это для 64 или для 32-бит версия? У меня работает только на 32-битной версии. При запуске на 64-битной версии не работает, еще и у XVM шрифты ломает.

После обновления хвм, нужно  мод накатить сверху. Т.к. хвм заменяет файлы мода на свои.

Share this post


Link to post

Short link
Share on other sites
5 минут назад, Scharfhobel сказал:

После обновления хвм, нужно  мод накатить сверху. Т.к. хвм заменяет файлы мода на свои

А я так и делаю. Ладно, буду разбираться, может конфликтует с другими модами.

У вас какой номер версии ночника XVM?

Edited by gizmojaf
.

Share this post


Link to post

Short link
Share on other sites

@gizmojaf попробуйте скачать VC Runtime и перезагрузитесь. Не поможет - пишите.

Share this post


Link to post

Short link
Share on other sites
2 часа назад, gizmojaf сказал:

А я так и делаю. Ладно, буду разбираться, может конфликтует с другими модами.

У вас какой номер версии ночника XVM?

Последний стоит xvm_8.5.4_0002

2 часа назад, Pavel3333 сказал:

@gizmojaf попробуйте скачать VC Runtime и перезагрузитесь. Не поможет - пишите.

[07C4:0FEC][2020-05-17T12:29:04]e000: Error 0x80070666: Cannot install a product when a newer version is installed.

Говорит стоит новее, а вот что, я без понятия.

Share this post


Link to post

Short link
Share on other sites
3 часа назад, Pavel3333 сказал:

попробуйте скачать VC Runtime и перезагрузитесь. Не поможет - пишите.

Спасибо за подсказку. Правда  по вашей ссылке это Visual C++2015 и с ним не пошло. Нашел в интернете более свежий пакет  Visual C++ 2019. Установил и с ним нормально заработало. vc_redist.x64.

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites
2020-05-17 21:26:13.670: INFO: [root] [XFW/Loader] Loading mod: com.modxvm.xfw.native, v. 2.0.1
2020-05-17 21:26:13.700: ERROR: [root] [XFW/Native] Error on loading native module 'python27.dll' from package 'com.modxvm.xfw.native'
Traceback (most recent call last):
  File "./src/wot_python/__init__.py", line 74, in load_native
ImportError: DLL load failed: The specified module could not be found.

2020-05-17 21:26:13.700: ERROR: [root] [XFW/Native] [init] Failed to load python27
2020-05-17 21:26:13.700: ERROR: [root] [XFW/Loader] Loading mod: 'com.modxvm.xfw.native' FAILED (flag)
2020-05-17 21:26:13.701: WARNING: [root] [XFW/Loader] Error with mod: 'com.pavel3333.mods.PositionsMod'. Feature failed: 'native' in package 'com.modxvm.xfw.native'

XVM не использую, и не собираюсь. 
 

после установки и попітки запуска мода python27.dll присутствует здесь:
%Wot%\mods\temp\com.modxvm.xfw.native\native_64bit\python27.dll

Share this post


Link to post

Short link
Share on other sites

При попытки скачать выдает

Цитата

Notice: Undefined index: user_status in /home/p/paveluk4/pavel3333.ru/public_html/download/load.php on line 159 Something wrong. Try again. Error 4. If the error persists, please, write to us on our VK group

 

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...