Jump to content
Korean Random
DroopyDog

Adding Tank Class Icon to Players Panel

Recommended Posts

Hi guys,

 

I have my config close to how I want it, but I want to see the tank class icon (HT, MT etc) in the players panel.

 

The individual vehicle icons from the tank atlas look nice, but I can't easily tell at a glance what tank class they are.

 

Attached is my playerspanel.xc file. I've added a definition for "vtypeIcon" (with code from a thread on this forum), and called the definition for the short and large panel configs in extrafieldsleft and extrafieldsright, but the icons do not appear.  I suspect the definition is not working, but I don't know how to fix it.

 

Can someone please advise what edits I need to make to the file?

 

Thanks, tank bro's!  

playersPanel.xc

Share this post


Link to post

Short link
Share on other sites

Heh you found my previous post.

 

I'm currently using this (haven't touched this definition in a while so I can't say if the earlier version still works for me): 

"format": "<font face='xvm' size='20' color='{{c:vtype}}'>{{vtype-key=LT?&#58;}}{{vtype-key=MT?&#59;}}{{vtype-key=HT?&#63;}}{{vtype-key=SPG?&#45;}}{{vtype-key=TD?&#46;}}</font>"

Edited by scyorkie

Share this post


Link to post

Short link
Share on other sites

Hey, deleting the XVM font in control panel worked! The icons now appear. Thanks Konrad.

And thanks for the code Scyorkie, does indeed work fine :-)

I notice the colors are different for each class...

If I want to make them the same, can I just change {c:vtype} to a hex colour value?

  

Share this post


Link to post

Short link
Share on other sites

I can't seem to get the syntax right to change the icon colour -- just trying to see patterns in other bits of code, because I don't know the language... 

 

I have tried: 

 

 "format": "<font face='xvm' size='20' color="0xFFCC66">{{vtype-key=LT?:}}{{vtype-key=MT?;}}{{vtype-key=HT??}}{{vtype-key=SPG?-}}{{vtype-key=TD?.}}</font>",
       "alpha": 90, "shadow": {}

 

 "format": "<font face='xvm' size='20' color='0xFFCC66'>{{vtype-key=LT?:}}{{vtype-key=MT?;}}{{vtype-key=HT??}}{{vtype-key=SPG?-}}{{vtype-key=TD?.}}</font>",
       "alpha": 90, "shadow": {}

 

 "format": "<font face='xvm' size='20' color='{0xFFCC66}'>{{vtype-key=LT?:}}{{vtype-key=MT?;}}{{vtype-key=HT??}}{{vtype-key=SPG?-}}{{vtype-key=TD?.}}</font>",
       "alpha": 90, "shadow": {}

 

"format": "<font face='xvm' size='20' color='{{vtype-key=LT?#E5E7E9}}{{vtype-key=MT?#E5E7E9}}{{vtype-key=HT?#E5E7E9}}{{vtype-key=SPG?#E5E7E9}}{{vtype-key=TD?#E5E7E9}}'</font>"

 

None of those made any difference....!

Edited by DroopyDog
Typo..

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...