Jump to content
Korean Random
ktulho

BattleTimer средствами XVM.

Recommended Posts

@HEKPOMAHT @ktulho , в шапке бы ссылку разместить (в "пример использования"), многим по душе будет такое оформление взамен нового.

  • Upvote 2

Share this post


Link to post

Short link
Share on other sites

в новом патче нормально работает или будет обновление под 1.4.1?

Edited by yanek

Share this post


Link to post

Short link
Share on other sites

Небольшая оптимизация. Обновил скрипт.

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites
3 часа назад, ktulho сказал:

Обновил скрипт.

в ЛФ не работает. В логах ошибок тьма, но связанных со скриптом нет.

----

закрыл клиент в обычном бою, снова зашёл - 00:00 показывает.

Share this post


Link to post

Short link
Share on other sites
40 минут назад, HEKPOMAHT сказал:

закрыл клиент в обычном бою, снова зашёл - 00:00 показывает.

Возможно поправил.

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites
16.06.2019 в 20:34, ktulho сказал:

Возможно поправил.

тоже нули в ЛФ

f5b3374662d5.jpg 

Edited by Slava7572

Share this post


Link to post

Short link
Share on other sites
16.06.2019 в 19:52, HEKPOMAHT сказал:

в ЛФ не работает.

Исправил. Обновил скрипт.

Share this post


Link to post

Short link
Share on other sites
1 час назад, ktulho сказал:

Исправил.

в лф после выбора новой техники нули, пока не сработает какое-нибудь событие

Share this post


Link to post

Short link
Share on other sites
2 минуты назад, HEKPOMAHT сказал:

в лф после выбора новой техники нули,

Одну секунду? Или может больше?

Share this post


Link to post

Short link
Share on other sites
1 минуту назад, ktulho сказал:

Одну секунду? Или может больше?

 

3 минуты назад, HEKPOMAHT сказал:

пока не сработает какое-нибудь событие

или риббон какой выскочит или полоса захвата появится

Share this post


Link to post

Short link
Share on other sites
19 минут назад, HEKPOMAHT сказал:

в лф после выбора новой техники нули,

Исправил.

Хотя нет, не исправил.

 

Вот теперь исправил.

  • Upvote 2

Share this post


Link to post

Short link
Share on other sites

Since nobody is reporting any issues, guess i am the only one...

I have some weird bug with prebattletimer update and can't figure out why.
let me try to explain.

So i use custom prebattle and battle timers with battletimer.py and beginbattle.py (both updated).
It worked without issue for long time, but last few patches started to act strange.

On one battle it loads normally and next one timer doesn't appear until battle starts.
No 30sec countdown (on prebattle timer or battle timer), it just stays on waiting... until battle starts, then top right timer (battle timer) appears like nothing happened.
Now interesting part is if i watch replay of that battle prebattle timer will work normally :blink:

I don't know if something is wrong with config and update event (did i miss some macro changes) or issue is when joining after prebattle timer started. :huh:
Again, it was working just fine few patches back (idk pre-1.5).
battleLabelsBattleTimer.xc      elements.xc

Example of "awaiting for player..." and prebattle timer (when works):
battletimer.thumb.png.1ecc6e80b4c4668bda576b38102f61e0.png

Share this post


Link to post

Short link
Share on other sites
22 минуты назад, Ress сказал:

У меня есть странная ошибка с обновлением prebattletimer и я не могу понять, почему.

"autoReloadConfig": false?

Share this post


Link to post

Short link
Share on other sites
54 minutes ago, ktulho said:

@Ress  updated script. Check.

Thanks, will do
 

 

47 minutes ago, HEKPOMAHT said:

"autoReloadConfig": false?

Yes. @xvm.xc

edit:

@ktulho
Updated py, played 3 battles both timers worked. :wink:
(however i did join before prebattle timer on all 3 games)

Edited by Ress

Share this post


Link to post

Short link
Share on other sites
18.06.2019 в 14:03, ktulho сказал:

Вот теперь исправил.

я только увидел, что баг для лини фронта исправлен... с этими объединениями сообщений действительно лажа полная. Хоть ты в другой теме сообщать :smile:

Share this post


Link to post

Short link
Share on other sites

Чет у меня не хочет работать в Стальном охотнике:sad:Логи чистые вроде.

Share this post


Link to post

Short link
Share on other sites

@Slava7572 , в данном режиме ничего кроме маркеров техники и лампы шестого чувства XVM не меняет.

Проще говоря "battleLabels" там не работают и ру-макросы там вывести негде.

Share this post


Link to post

Short link
Share on other sites
48 минут назад, night_dragon_on сказал:

не работают и ру-макросы

Окей,а еще вопрос,я родной таймер за пределы моника задвинул в сниппетах

"battleTimer":                    { "y": -30 }

нельзя же вот такое например проделать,там же макросы не пашут?

"battleTimer":                    { "y": {{battletype=battle_royale_solo?0|-30}} }

В доках что то не вижу

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...