Jump to content
Korean Random
Kotyarko_O

battleMessages средствами XVM.

Recommended Posts

 

 

По какой причине сообщения о тимдамаге могут двоиться?

Была у меня такая же фигня - выключил autoReloadConfig и перезапустил клиент. 

Перестало в глазах двоиться ))

Share this post


Link to post

Short link
Share on other sites

сюда бы еще добавить отправку в чат информацию по кнопке С о перезарядке

  • Upvote 1
  • Downvote 1

Share this post


Link to post

Short link
Share on other sites

сюда бы еще добавить отправку в чат информацию по кнопке С о перезарядке

это настраивается в игре, без модов

Share this post


Link to post

Short link
Share on other sites

Всем привет!

У меня при засвете в чате вот такое творится:

post-31170-0-93103300-1482608294_thumb.jpg

Подскажите, как с этим бороться ))

Логи.rar

Edited by Jack_ppc

Share this post


Link to post

Short link
Share on other sites

Подскажите, как с этим бороться ))

Выровнять мне руки и заставлять проверять всё, что сделал, прежде чем выложить)

 

Обновлено.

  • Исправлена заморозка команды "Нужна помощь!".
  • Upvote 4

Share this post


Link to post

Short link
Share on other sites

Исправлена заморозка команды "Нужна помощь!".

 

Спасибо, оперативненько ))

 

А на руки не наговаривай - они в порядке :gg:

И нам, ракам, только в радость все ваши изобретения покатать!

Share this post


Link to post

Short link
Share on other sites
Обновлено

 

Спасибо.

А можно еще хотелки из мода observed перенести в Ваш мод следующее в части засвета:

    <!-- Использвать чат взвода, если он найден -->
    <!-- ОБРАТИТЕ ВНИМАНИЕ на особенность работы опции: -->
    <!--      пока во взводе больше одного живого игрока, то в чат взвода отправляется сообщение о засвете, -->
    <!--      причем ни прикликивание, ни сообщение "Нужна помощь" не отправляется. Как только во взводе остается -->
    <!--      один живой игрок, то все начинает работать как обычно, то есть сообщение о засвете идет в тимчат, -->
    <!--      а прикликивание и сообщение "Нужна помощь" отправляются если влючены опции. -->
    <useSquadChat>1</useSquadChat>
   
    <!-- Опции сообщения по окончании "предполагаемого" засвета -->
    <!-- Через сколько секунд отображать сообщение на правой панели (над миникартой) -->
    <!-- Для отключения установить параметр timeEndMessage в 0 -->
    <!-- ЗНАЧЕНИЕ ПО УМОЛЧАНИЮ: "10" -->
    <timeEndMessage>12</timeEndMessage>
   
    <!-- Собственно, само сообщение -->
    <!-- Подстановки: -->
    <!--      {time} - значение параметра timeEndMessage (см. выше) -->
    <!-- ЗНАЧЕНИЕ ПО УМОЛЧАНИЮ: "Прошло уже {time} секунд. Возможно ты уже не светишься. Вперед за дамажкой!" -->
    <endMessage>Прошло {time} секунд, возможно не светишься.</endMessage>
Edited by refaol

Share this post


Link to post

Short link
Share on other sites

Это случилось единожды или повторяется регулярно?

Дело в том, что тут отправляется одно сообщение, заморозка при этом не может отрабатывать. Вероятно, в этот момент было два отдельных события, которые отправляли команду в чат.

Share this post


Link to post

Short link
Share on other sites

Было не единожды, это точно. Попробую еще поймать.

Реплей, если что, прикладывать?

Share this post


Link to post

Short link
Share on other sites

Было не единожды, это точно. Попробую еще поймать.

Реплей, если что, прикладывать?

Да, реплей будет кстати.

Share this post


Link to post

Short link
Share on other sites

@Kotyarko_O, поймал с двумя попаданиями от арты:

post-31170-0-60065600-1483039364_thumb.jpg

Появилось после изменения конфига при включенном "autoReloadConfig". Так же начинает дублироваться сообщение о тимдамаге (реплея пока нет).

После перезагрузки клиента все становится нормальным до тех пор, пока опять не изменить как-нибудь конфиг.

replay_last_battle.wotreplay             python.log              xvm.log

Share this post


Link to post

Short link
Share on other sites

 

 

Появилось после изменения конфига при включенном "autoReloadConfig". Так же начинает дублироваться сообщение о тимдамаге (реплея пока нет). После перезагрузки клиента все становится нормальным до тех пор, пока опять не изменить как-нибудь конфиг.
То есть, при выключенной перезагрузке конфига всё ок? Если да, то это проблема на стороне самого XVM.

Share this post


Link to post

Short link
Share on other sites

Если да, то это проблема на стороне самого XVM.

 

Получается, да. Значит соберу все скрины и реплеи с багами и пойду стучаться к sirmax'у ))

Share this post


Link to post

Short link
Share on other sites

@Jack_ppc, а вообще, с "autoReloadConfig" лучше на реплеях гонять. Хотя... если речь про арту идёт, то можно и в бою)

Share this post


Link to post

Short link
Share on other sites

Получается, да. Значит соберу все скрины и реплеи с багами и пойду стучаться к sirmax'у ))

Только до 8 января у меня компа не будет.

Share this post


Link to post

Short link
Share on other sites

Только до 8 января у меня компа не будет.

 

Итить колотить!

Тогда удачных праздников и легкого похмелья ))))))))))

С наступающим!

Edited by Jack_ppc

Share this post


Link to post

Short link
Share on other sites

@Jack_ppc, странные в логе ошибки. Как-будто, конфиг battleMessages.xc не всегда подгружается. Такое наблюдается после выхода\вылета во время боя и повторного входа?

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×