Jump to content
Korean Random
Kotyarko_O

battleMessages средствами XVM.

Recommended Posts

А такое уже возможно. Я в ЛФ не катал, но подозреваю, что это происходит при артобстреле. Если такая ситуация попадётся, буду благодарен за реплей.

Share this post


Link to post

Short link
Share on other sites

@Kotyarko_O тестил хитлог, попалась ошибка из этой темы :smile:

2019-06-21 20:23:48.373: INFO: =============================
2019-06-21 20:23:48.373: INFO: 2019-06-21 20:23:48: [ERROR] mods/xfw/python/xfw/events.pyc
2019-06-21 20:23:48.373: ERROR: Traceback (most recent call last):
2019-06-21 20:23:48.373: ERROR:   File "mods/xfw/python/xfw/events.py", line 57, in __event_handler
2019-06-21 20:23:48.374: ERROR:   File "mods/xfw/python/xfw/events.py", line 24, in fire
2019-06-21 20:23:48.374: ERROR:   File "res_mods/configs/xvm/py_macro\battleMessages.py", line 87, in showDamageFromExplosion
2019-06-21 20:23:48.375: ERROR:     showEnemyArtyCooldown(self, attackerID)
2019-06-21 20:23:48.375: ERROR:   File "res_mods/configs/xvm/py_macro\battleMessages.py", line 72, in showEnemyArtyCooldown
2019-06-21 20:23:48.375: ERROR:     if vehicles.getVehicleClass(attacker['vehicleType'].type.compactDescr) == VEHICLE_CLASS_NAME.SPG:
2019-06-21 20:23:48.375: ERROR: TypeError: 'NoneType' object has no attribute '__getitem__'
2019-06-21 20:23:48.375: INFO: =============================

ошибка battleMessages.wotreplay

----

обнаружил с ammo_ctrl.py на реплее ещё одну:

2019-06-21 20:31:10.402: INFO: =============================
2019-06-21 20:31:10.403: INFO: 2019-06-21 20:31:10: [ERROR] mods/xfw/python/xfw/events.pyc
2019-06-21 20:31:10.403: ERROR: Traceback (most recent call last):
2019-06-21 20:31:10.403: ERROR:   File "mods/xfw/python/xfw/events.py", line 56, in __event_handler
2019-06-21 20:31:10.404: ERROR:   File "scripts/client/gui/shared/utils/MethodsRules.py", line 61, in wrapper
2019-06-21 20:31:10.405: ERROR:   File "scripts/client/gui/battle_control/controllers/consumables/ammo_ctrl.py", line 521, in setGunReloadTime
2019-06-21 20:31:10.405: ERROR:   File "scripts/client/gui/battle_control/controllers/consumables/ammo_ctrl.py", line 575, in triggerReloadEffect
2019-06-21 20:31:10.406: ERROR: KeyError: None
2019-06-21 20:31:10.406: INFO: =============================
2019-06-21 20:31:10.557: ERROR: [Vehicle] respawn vehicle: Vehicle ref is not None but entity does not exist anymore. Skip wg_respawn
2019-06-21 20:31:10.649: WARNING: DAPI AttachMovie() depth requested (71) for symbol "com.xvm.vehiclemarkers.ui::XvmVehicleMarker" is too large. Using next highest index (47) instead.

стоит в ночники репорт отставить или она тоже случайная? 

Share this post


Link to post

Short link
Share on other sites
3 hours ago, HEKPOMAHT said:

стоит в ночники репорт отставить или она тоже случайная? 

Не, это чисто клиентская.

Share this post


Link to post

Short link
Share on other sites
9 часов назад, Kotyarko_O сказал:

Не, это чисто клиентская.

и верхняя с battleMessages.py? То есть обе клиентские, я правильно понял?

Share this post


Link to post

Short link
Share on other sites
51 minutes ago, HEKPOMAHT said:

и верхняя с battleMessages.py? То есть обе клиентские, я правильно понял?

Не, клиентская только вторая. Первую буду смотреть, чуть позже.

Share this post


Link to post

Short link
Share on other sites

Is there a solution with the battleMessages.py? Only der Arty Message won't work. Rest is ok. Thanks.

Share this post


Link to post

Short link
Share on other sites
44 minutes ago, Heliomalt said:

Is there a solution with the battleMessages.py? Only der Arty Message won't work.

I`ve checked it and "enemyArtyCooldown" feature is working normally. Please, attach logs and your battleMessages.xc.

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

@Heliomalt, i don`t know if it possible to get attacker vehicle type in "fog of war" mode. So now i can only make this addon ignore cases like that.

 

Обновлено.

  • Исправлена ошибка, возникающая при артобстреле в режиме "Линия фронта".
  • Исправлена ошибка, возникающая при попадании в игрока артиллерии, находящейся в "тумане войны".
  • Upvote 1

Share this post


Link to post

Short link
Share on other sites
20 minutes ago, Heliomalt said:

but it seems clip reload is not working anymore, played one battle with the Lorraine, press two times C, clip is reloading, but no message in battlechat.

Hmm... works for me.

You have some problems with xvm installed. From your logs:

2019-07-08 16:37:35: [ERROR] Traceback (most recent call last):
  File "res_mods/mods/xfw_packages\xvm_main\python\python_macro.py", line 127, in load_macros_lib
    code = load(file_name)
  File "res_mods/mods/xfw_packages\xvm_main\python\python_macro.py", line 101, in load
    return parse(source, file_name)
  File "res_mods/mods/xfw_packages\xvm_main\python\python_macro.py", line 91, in parse
    node = ast.parse(source)
  File "scripts/common/Lib/ast.py", line 37, in parse
  File "<unknown>", line 1
    <!DOCTYPE html>
    ^
SyntaxError: invalid syntax
....
2019-07-08 16:38:05: xvm_integrity results: incorrect!
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_battle/as_battle/xvm_vehiclemarkers_ui.swf
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_battle/as_battle_classic/xvm_battle_classic.swf
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_battle/as_battle_epicbattle/xvm_battle_epicbattle.swf
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_battle/as_battle_epicrandom/xvm_battle_epicrandom.swf
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_battle/as_battle_ranked/xvm_battle_ranked.swf
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_battle/python/replay.py
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_lobby/as_lobby/xvm_lobby.swf
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_lobby/as_lobby/xvm_lobby_ui.swf
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_main/python/default_config.py
	hash mismatch in file: res_mods/mods/xfw_packages/xvm_online/python/online.py

Also, try to remove other modifications.

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

@Kotyarko_O 

 

 I switch back to 7.9.7, use the latest battleMessages.py, thats the result: python.logxvm.log 

 

With py macro from May 11. there is no error:python2.logxvm2.log

 

But on both version, no clip reload message anymore. This is strange, because it worked for month.

Edited by Heliomalt
typo

Share this post


Link to post

Short link
Share on other sites
10 minutes ago, Heliomalt said:

But on both version, no clip reload message anymore. This is strange, because it worked for month.

What about your battleMessages.xc? Do the option "clipCooldownTimeMsgOnReload\enabled" in "true"? Maybe you`ve refreshed your config and forgot it =)

Edited by Kotyarko_O
  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

@Kotyarko_O 

 

I changed nothing in the xc file, but I do another test, I use the py and the xc file from the zip in the start post, use it together with a default xvm 7.9.7, nothing else. No clip message.

battleMessages.xc xvm3.log python3.log @ xvm.xc

 

I have cleaned the whole wot cache, inclusive xvm folder, fixed. I don't understand, why cleaning the cache fix this, strange. But anyway, thx for help.

Edited by Heliomalt
Solution found

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...