Jump to content
Korean Random
Tuzik_Baskerville

Парочка багов в XVM 6.4.0 (шансы, утечка памяти)

Recommended Posts

Спасибо за уточнение! Удалил игру под 0. Переустановил с сервера.Запустил рэплей. На 16 скорости прогнал, после 10 нажатия кнопки назад, получил сообщение о нехватке памяти! Без участия XVM. Также прикрепляю отчет WGChek (расширение txt надо убрать). Может что-то не так сделал!

post-37981-0-13189600-1473447794_thumb.jpg

post-37981-0-65260900-1473447794_thumb.jpg

python 10.log

WoT_report.wgc.txt

Share this post


Link to post

Short link
Share on other sites

Может что-то не так сделал!

Не обновился до нормальной ОС.

У тебя ж там явно какой-то кривой, собранный малолетним рукожопом дистрибутив винды. Наверняка "оптимизированный", в котором вырезано "все не нужное". Остается только страдать.

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

 

 

получил сообщение о нехватке памяти! Без участия XVM.

Ну вот всё и понятно) Тогда писать разработчикам XVM это бессмысленно, раз у тебя чистый клиент течёт) Это к ВГ уже и к твоей ОС )

Share this post


Link to post

Short link
Share on other sites

... Может что-то не так сделал!

а сам как думаешь ?

имея на борту 8гб оперативы,

http://www.koreanrandom.com/forum/topic/33573-связанно-с-xvm-или-нет-утечка-памяти/?p=351783

ставить 32_битную винду у которой ещё раз повторю...максимум 3.6 гб в дуале используется..а никакие не 4гб...как ты пишешь...

http://www.koreanrandom.com/forum/topic/33573-связанно-с-xvm-или-нет-утечка-памяти/?p=352060

ставь нормальную W7 x64 и уже на ней тестируй

Edited by tricsi

Share this post


Link to post

Short link
Share on other sites
Не обновился до нормальной ОС. У тебя ж там явно какой-то кривой, собранный малолетним рукожопом дистрибутив винды. Наверняка "оптимизированный", в котором вырезано "все не нужное". Остается только страдать.

 У меня 3 Оси стоит на разных жестких дисках.На win 7 тож же эффект ранее был. Попробую  повторить на ней! Но то что xvm перестал вносить свой вклад после доработки , факт! В боевой работе сбоев не было на 15 боях.

Edited by Георгий В

Share this post


Link to post

Short link
Share on other sites

Уж не знаю, подустал перебирать и пробовать, но пока ощущение, что в 6444 не течёт, а 6457 утечка есть. Или какой-то ещё эффект накладывается. Мне было показалось, что в рандоме нет утечки, а в вылазках есть , потом вроде нет такой зависимости.

Share this post


Link to post

Short link
Share on other sites

Вот как выглядит график : несколько боёв в рандоме, битва за укреп, снова рандом. Что мне пришло в голову: только цифра номера в маркерах вроде заметное отличие. Реплеи есть, если кто захочет покрутить или подскажет мне как добыть полезную информацию. 

post-31869-0-72642400-1473712984_thumb.png

Edited by Elyas

Share this post


Link to post

Short link
Share on other sites

На одном реплее попробуй помотать назад несколько раз, будет течь?

Share this post


Link to post

Short link
Share on other sites

У кого-нибудь еще такое наблюдается?

 

Добрый день! Мучаюсь уже 1.5 месяца/? с момента обновления по микропатчу 9.15.1.1. Пинги отключены. Перезахожу в игру каждые 6-7 боев.Стоит последний XVM в cборке Zeus 002

 

Win 7 32. 3гб ОЗУ, Nvidia 310M

Share this post


Link to post

Short link
Share on other sites

У меня таки выдало сообщение о памяти, но внимание - клиент не закрывался 82 боя в течение 2-х суток. По Process Explorer'у память была всё те же 1,2Гб не более, что странно. На XVM грех жаловаться двое суток это нереал, столько не играют. Да и другими модами я был "обмазан" по самое не могу. )))

Edited by Tuzik_Baskerville

Share this post


Link to post

Short link
Share on other sites

У меня таки выдало сообщение о памяти, но внимание - клиент не закрывался 82 боя в течение 2-х суток. По Process Explorer'у память была всё те же 1,2Гб не более, что странно. На XVM грех жаловаться двое суток это нереал, столько не играют. Да и другими модами я был "обмазан" по самое не могу. )))

возможно будет лучше

15 сентября на общем тесте вышло небольшое обновление:

....

исправлена проблема с утечкой памяти;

....

Share this post


Link to post

Short link
Share on other sites

Вин ХР СП3

на чистом клиенте всё норм

 

Клиент + xvm-6.4.6.2 - "недостаточно памяти" уже на третьем бое.

Поиграл сегодня 10-12 боёв. На 4-м бое пропали иконки танков в ушах и отметки союзных танков на миникарте. В следующем бою появились снова. В самом последнем бою снова пропали.

Все бои, начиная с третьего сопровождались сообщением о недостатке памяти.

Поскольку за 10 боёв ни разу не выкинуло, то, пожалуй, это терпимо.

Тем не менее, прикладываю скрины и логи.

 

1.Перед боем в ангаре:

ac51e270a85d31c3eb234f748fa7097b-full.jp

 

2. После первого боя

d39a2fd08a4b5845af3f2f64cc93b0c8-full.jp

 

3. После 3-го боя, в начале которого появилось сообщение о нехватке памяти

1ba5e18561831fb8d29484cbed620e64-full.jp

 

4. После 4-го боя, в котором пропали иконки

4e3fea10230f410866b3a0729afb8794-full.jp

 

5. В следующем бою иконки появились.

601b6c6a30887c23a76cea317fa834f1-full.jp

 

Я делал подобные скрины после каждого боя. Но на мой неискушённый взгляд, графики везде одинаковые, поэтому выкладываю только половину нафотанного.

python.log

xvm.log

Share this post


Link to post

Short link
Share on other sites

Играю на калькуляторе: атлон64х2 6000, 550ti, XPSP3, 4гига оперативы. Проблема с нехваткой памяти решилась переходом со стандартной графики на улучшенную, возвращаюсь на стандартную -- опять не хватает. В прошлом патче стабильно держались 60-70 фпс, в 9.16 появились просадки до 26 в снайп и арт режимах. Установлены прицелы, pmod, XVM

post-17506-0-97324900-1476267255_thumb.jpg

post-17506-0-67640200-1476267259_thumb.jpg

post-17506-0-26806500-1476267265_thumb.jpg

Edited by BAPBAP23
  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

была проблема с просадкой фпс аж до -20 фпс в снайперском режиме...мне подсказали обновить  адоб флеш плеер...

потом методом тыка выяснилось что просадка идет из-за того что не стоит галочка в настройках на тройная буферизация..поставил и фпс стал норм.

 

короче ставь все три галочки что на скрине 2  

(вертикальная... даёт фпс, что может моник (60-75Гц) , а без неё ,что видюха

Edited by mikesds
  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

Спасибо, mikesds и BAPBAP23.

Проблема почти решилась. ФПС просел, но на терпимом уровне 30-40.

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...