Jump to content
Korean Random
SkepticalFox

Blender Tank Viewer

Recommended Posts

21 minutes ago, Spectr20 said:

отказывается экспортировать

а кто-то им пользуется?) он же багованый, лучше офф экспортером из unified editor'а пользоваться для Maya

Share this post


Link to post

Short link
Share on other sites
1 час назад, SkepticalFox сказал:

а кто-то им пользуется?)

Ну видимо только я, я пользовался им для сборки 3D стилей, ну и для редактирования тоже.

Edited by Spectr20

Share this post


Link to post

Short link
Share on other sites

Привет поч такая ошибка вылазит? Это только при открытии новых танков с 4мя гуслями...

Screenshot_17.png

Share this post


Link to post

Short link
Share on other sites
22.01.2022 в 12:18, Spectr20 сказал:

Собственно вопрос почему траки так себя ведут?

2022-01-22_135313.png

нужно в файле BigWorldModelLoader.py после (я добавил после, может и до - не важно.)

ob_mod_Array.constant_offset_displace[1] = model['segmentOffset']

добавить                   

 ob_mod_Array.constant_offset_displace[0] = 0


 

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites
2 часа назад, brd2k7 сказал:

нужно в файле BigWorldModelLoader.py после (я добавил после, может и до - не важно.)

Я вас категорически благодарю! 

Share this post


Link to post

Short link
Share on other sites
On 1/28/2022 at 12:18 PM, Spectr20 said:

На новой версии отказывается экспортировать , и настроек при экспорте ни каких.

вроде пофиксил

On 1/29/2022 at 11:34 AM, brd2k7 said:

нужно в файле BigWorldModelLoader.py после (я добавил после, может и до - не важно.)

это тоже пофиксил, спасибо

  • Upvote 2

Share this post


Link to post

Short link
Share on other sites
35 минут назад, SkepticalFox сказал:

вроде пофиксил

Вот спасибо большое

Share this post


Link to post

Short link
Share on other sites

Ребят не подскажите как подгружать 3D стили ? Что-то понять не могу. 

Share this post


Link to post

Short link
Share on other sites

Thank you for the update, both the Tankviewer and import/export plugins appear to be working great! I do have a couple of issues to report:

 

1. Regarding the import/export plugin, attempting to export using an empty containing multiple separate objects (which worked in the old Blender 2.79 version) returns the following error message:

 

unknown.png

 

Exporting with everything merged into one singular object seems to function as normal, so it is not a big issue, but this is something which appears to be new to this version.

 

2. Regarding the Tankviewer plugin, attempting to load any of the new Yoh tanks results in an error + no model loading. Probably to do with the chassis, same as when trying to load AE Phase 1.

 

Thank you once again for your work. :great:

Edited by FastestClassic
Fixed incomplete message

Share this post


Link to post

Short link
Share on other sites
12 hours ago, FastestClassic said:

1. Regarding the import/export plugin, attempting to export using an empty containing multiple separate objects (which worked in the old Blender 2.79 version) returns the following error message:

I think I fixed it, pushed, didn't check

(I haven't checked this add-on at all)

Edited by SkepticalFox
  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

После обновления плагин импорта/экспорта моделей перестал загружать более одной модели.

Share this post


Link to post

Short link
Share on other sites
24 минуты назад, SkepticalFox сказал:

можно пример было-стало?

А вот с этим беда у меня старой версии скрипта не осталось

Share this post


Link to post

Short link
Share on other sites
20.02.2022 в 22:13, SkepticalFox сказал:

ну тогда на каких файлах можно проверить это?

Так чудом я нашёл старую версию

io_bigworld_model.zip

Share this post


Link to post

Short link
Share on other sites

@Spectr20 но я по прежнему не представляю как воспроизвести эту регрессию, можно немного поподробнее?

  • Upvote 1

Share this post


Link to post

Short link
Share on other sites
On 2/14/2022 at 12:32 PM, SkepticalFox said:

I think I fixed it, pushed, didn't check

(I haven't checked this add-on at all)

 

This appears to have fixed that issue; however, I am now getting an "Error in import" message when importing hull or turret .model sets manually. Gun and chassis files import without issue, but turret and hull models fail to load. Tested with several different 3D styles, including Battle Pass E4/Leopard, Type 5 Heavy, T-54 mod 1, etc.

 

From Blender Info Log (using Type 5 3Dst turret as an example):

Quote

Error in import `C:\Tanks\3D Styles\J20_Type_2605_3Dst\normal\lod0\Turret_01.model`!

 

From console output:

Quote

============
Info: import `E:\WoT Res\3D Styles\1.11.1 Type 5 Heavy\J20_Type_2605_3Dst\normal\lod0\Turret_01.model`
E:\WoT Res\3D Styles\1.11.1 Type 5 Heavy\J20_Type_2605_3Dst\normal\lod0\Turret_01.primitives_processed vertices indices
Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 3.0\3.0\scripts\addons_contrib\io_bigworld_model\__init__.py", line 246, in execute
    bw_model.load_from_file(self.filepath, self.import_empty)
  File "C:\Program Files\Blender Foundation\Blender 3.0\3.0\scripts\addons_contrib\io_bigworld_model\import_bw_primitives.py", line 99, in load_from_file
    dataMesh = LoadDataMesh(primitives_filepath, vres_name, pres_name, uv2_name)
  File "C:\Program Files\Blender Foundation\Blender 3.0\3.0\scripts\addons_contrib\io_bigworld_model\loaddatamesh.py", line 43, in __init__
    self.__load_XYZNUV(
  File "C:\Program Files\Blender Foundation\Blender 3.0\3.0\scripts\addons_contrib\io_bigworld_model\loaddatamesh.py", line 186, in __load_XYZNUV
    N = bwm_UnpackNormal_tag3(n)
  File "C:\Program Files\Blender Foundation\Blender 3.0\3.0\scripts\addons_contrib\io_bigworld_model\common\__init__.py", line 109, in bwm_UnpackNormal_tag3
    pkz = (packed>>16)&0xFF^0xFF
TypeError: unsupported operand type(s) for >>: 'Vector' and 'int'

 

EDIT: Tested with a couple normal (non-style) tank models as well. Produces the same issue.

Edited by FastestClassic
More testing

Share this post


Link to post

Short link
Share on other sites

Переустановил винду теперь плагин не запускается выдает ошибку. Blender 3.0. Не подскажите как решить ? 

1.jpg

Share this post


Link to post

Short link
Share on other sites

Проблема решена. Спасибо за помощь. Удачи с развитием. 

Share this post


Link to post

Short link
Share on other sites

Hello. Is there currently a way to select 3D skins for tanks in Blender 2.93? If not, is there a way to import them into Blender?

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...