Jump to content
Korean Random
GPCracker

Маркеры направления орудий на миникарте / Minimap Gun Markers

Recommended Posts

Особенно часто при игре на арте(((

Маркеры рисуются в пределах квадрата отрисовки. Часть карты за пределами квадрата отрисовки. Чтобы арта могла стрелять через всю карту, ей квадрат отрисовки смещается в точку прицеливания в арт режиме. Соответственно, она не может видеть маркеры рядом с собой, если смотрит в другой угол карты. Клиент не имеет никакой инфы о танках за пределами квадрата отрисовки. Маркеры на миникарте добавляются при помощи костылей от ВГ. Это уже обсуждалось в этой теме.

Периодически указки пропадают с карты (через секунду, две, пять появляются вновь)

Посмотри фпс в момент переключения. Посмотри в логи. У меня таких лагов ни разу не наблюдалось.

всё работает с картой от локостан на ура

С миникартой локастана я не играю. Поэтому непосредственно дебажить под нее не могу (это весьма длительный процесс). Я обеспечиваю работу мода в той конфигурации, с которой играю (ХВМ), плюс могу вынести какие-то калибровочные параметры в конфиг, на основе той отладочной информации (логов и скриншотов), которую вы сюда скидываете. Edited by GPCracker

Share this post


Link to post

Short link
Share on other sites

Маркеры рисуются в пределах квадрата отрисовки.

 

Это не совсем верно))) По крайней мере у меня)))))

Может на XVM всё работает ровно...не знаю, но на карте локастана Ваш мод работает как-то чудно)))

 

post-14793-0-70452700-1420458753_thumb.jpg

Share this post


Link to post

Short link
Share on other sites

Это не совсем верно))) По крайней мере у меня))))) Может на XVM всё работает ровно...не знаю, но на карте локастана Ваш мод работает как-то чудно)))

Как минимум для арты мод показал направление. Противники, как я понял, отключены в конфиге. Указка добавлена к маркеру направления аркадной камеры... Который и используется модом. Миникарта локастана позволяет иметь только одну такую указку. Вот и объяснение чудностей. Миникарта локастана по ходу дела работает чисто на флеше, без подвязки скриптов. В плане быстродействия она скорее всего резче ХВМ, в котором все сделано скриптами, однако такой подход делает ее неудобной для адаптации мода. Для адаптации под нее мода скорее всего потребуется согласование с локастаном. По крайней мере я могу скинуть некоторую информацию, по связи скрипта с флешем со стороны питона. Возможно это поможет Вам выяснить у автора этой миникарты команды для отрисовки маркеров орудий.

"Немного кода"

self.minimapEntry.addEntry(combinedMP, zIndex)

self.minimapEntry.invokeEntry('gotoAndStop', ['cursorNormal'])

MP is a matrixProvider, see BigWorld python docs. It descript location and rotation.

Key parameters here are zIndex, 'gotoAndStop', ['cursorNormal']

They should be in a "frontend" of Flash.

Share this post


Link to post

Short link
Share on other sites

С последнем билдом хвм 3660 работает.Правда включил в конфиге 

 

 

<displayFilters>
  <filter>
   <!-- Состояние фильтра (включен/отключен). -->
   <enabled>True</enabled>
   <!-- Состояние фильтра (активен/неактивен). -->
   <activated>True</activated>

 

Share this post


Link to post

Short link
Share on other sites

Это не совсем верно))) По крайней мере у меня)))))

Для арты центр квадрата отрисовки в точке, куда наведен прицел (арт режим)

При переходе обратно в аркадный квадрат перемещается "под арту", поэтому наблюдаются некоторые лаги при переходе между режимами, когда светится много противников. Ибо при перемещении квадрата сервер передает туеву хучу информации об тех танках, которые "появляются" в квадрате отрисовки игрока.

Правда включил в конфиге

Направления стволов противников отключены в конфиге по умолчанию.

Share this post


Link to post

Short link
Share on other sites

 

Маркеры рисуются в пределах квадрата отрисовки.

Я уж думал мод глючит,не знал:)

Share this post


Link to post

Short link
Share on other sites

 Может дело то было в ранних XVM..........

 

Поставил 3660 + мод= пару боёв сиграл ....вроде норм ...хз хз

Share this post


Link to post

Short link
Share on other sites

Я уж думал мод глючит,не знал:)

Ограничение движка. Там в шапке написано. Игрок не знает ничего о вещах за пределами магического квадрата.
  • Upvote 1

Share this post


Link to post

Short link
Share on other sites

Что-то я рано порадовался;( В добавок к простым маркерам направления добавились и белые стрелки через всю карту.
post-13619-0-60345700-1420738820_thumb.jpg
Напомню использую карту от локостана.

Edited by SeVeRRR

Share this post


Link to post

Short link
Share on other sites

Что-то я рано порадовался;( В добавок к простым маркерам направления добавились и белые стрелки через всю карту.

Указка добавлена к маркеру направления аркадной камеры... Который и используется модом.

 

Если хотите маркеры на миникарту локастана, согласовывайте с ним "хвосты" для управления миникартой через DAAPI. Свои я выкладывал уже.

 

self.minimapEntry.addEntry(combinedMP, zIndex)
self.minimapEntry.invokeEntry('gotoAndStop', ['cursorNormal'])
#MP is a matrixProvider, see BigWorld python docs. It descript location and rotation.
#MP is translated to minimap in C-part of game engine.
#Key parameters here are zIndex, 'gotoAndStop', ['cursorNormal'] They should be in a "frontend" of Flash.

 

Edited by GPCracker

Share this post


Link to post

Short link
Share on other sites

Приветствую. У меня одна проблемка с модом.

У меня в системе используется программа с управлением горячими клавишами и при использовании некоторых сочетаний клавиш мод циклично включается/выключается. А именно при использовании сочетаний в которых используется клавиша Win (windows) и любая кнопка мыши (или даже прокрутка колеса).

Например такие: Win+LMouse или Win+MouseWheelUp

При нажатии, маркеры орудий на карте полностью исчезают, как при отключении мода (при этом информ.сообщение о вкл/выкл мода не появляется и родным сочетанием клавиш мод обратно не включается), после повторного нажатия сочетания клавиш маркеры снова появляются.

Замечена проблема только при использовании именно такого сочетания (Win + Мышь), другие сочетания (только клавиатурные или без использования Win) похоже не срабатывают.

При этом, какое именно действие завязано на сочетании клавиш, не имеет значения, даже если действие отсутствует. Важно только наличие хука на данное сочетание клавиш в сторонней программе. Используемая программа также не важна (проверялось на нескольких программах использующих управление горячими клавишами и поддерживающими использование сочетаний Win+Мышь).

Share this post


Link to post

Short link
Share on other sites

Приветствую. У меня одна проблемка с модом.

Логи и конфиг в студию. Экстрасенсов тут нет.

Share this post


Link to post

Short link
Share on other sites

Логи и конфиг в студию. Экстрасенсов тут нет.

Ах да, забыл про это, но просто потому, что конфиг - дефолтный из архива, а лог - чистый (не отличается от лога чистого клиента + сообщения о загрузке собственно модов). Но все же прикладываю лог. python.log

 

Тем временем обнаружил, что указанный глюк происходит в связке с этим модом: http://forum.worldoftanks.ru/index.php?/topic/1464199-095-%D0%BC%D0%BE%D0%B4-%D0%B8%D0%BD%D0%B4%D0%B8%D0%BA%D0%B0%D1%82%D0%BE%D1%80-202-21112014-%D1%80%D0%B0%D1%81%D1%88%D0%B8%D1%80%D0%B5%D0%BD%D0%BD%D0%B0%D1%8F-%D0%B8%D0%BD%D0%B4%D0%B8%D0%BA%D0%B0%D1%86%D0%B8%D1%8F-%D0%B0%D0%B2%D1%82%D0%BE/

Приложенный лог как раз от клиента только с двумя упомянутыми модами.

Edited by poget

Share this post


Link to post

Short link
Share on other sites

Что-то я рано порадовался;( В добавок к простым маркерам направления добавились и белые стрелки через всю карту.

attachicon.gifshot_050.jpg

Напомню использую карту от локостана.

просто на ноль ставиш направления орудия в хмлке и всё !будет как у меня 

post-20675-0-47222700-1420914996_thumb.jpg

Share this post


Link to post

Short link
Share on other sites

Тем временем обнаружил, что указанный глюк происходит в связке с этим модом: http://forum.worldof...индикация-авто/ Приложенный лог как раз от клиента только с двумя упомянутыми модами.

Посмотреть, что творит этот мод я не могу, не декомпилится файлик, но что-то опаздывает с запросом к удаленному объекту...

Share this post


Link to post

Short link
Share on other sites

Посмотреть, что творит этот мод я не могу, не декомпилится файлик, но что-то опаздывает с запросом к удаленному объекту...

Да, тот мод закодирован. Поэтому смог поковыряться только в этом.

Сделал себе пока костыль. Удалил из мода функцию обработки клавиш "handleKeyEvent". Так все работает (естественно не считая управления с клавиатуры).

Еще помогает удаление вызова "updateMinimap()" из той же функции. (видимо надо его глубже копать)

А еще заметил, что при дефолтном конфиге, указанное мной сочетание (win+mouse) включает/выключает мод в обход встроенной функции без вывода каких-либо сообщений, но если в конфиге изменить стандартный хоткей "KEY_LCONTROL+KEY_M" на "KEY_NONE", тогда то же самое сочетание (win+mouse) уже срабатывает как встроенный хоткей с выводом стандартных сообщений (мод включен/выключен).

Ладно, появится время, еще поковыряюсь.

 

upd:

Ну, вроде разобрался.

Весь затык происходит когда в функции "handleKeyEvent" проверяется совпадение нажатых клавиш с сочетаниями в конфиге (для включения/выключения мода, либо отдельных фильтров). По невыясненной причине, указанные мной сочетания (Win+Mouse) присылают код клавиши = "0". При парсинге хоткеев из конфига все "KEY_NONE" превращаются в "0". В итоге 0=0 и все "KEY_NONE" отрабатываются как нажатые хоткеи, а т.к. в дефолт конфиге все фильтры имеют хоткей "KEY_NONE", то по волшебному сочетанию (Win+Mouse) все фильтры включаются/выключаются.

Почему данное сочетание приобретает значение "0" и как это связанно с другим, указанным мной, модом, я не знаю, тут надо еще и исходник второго мода смотреть.

Короче я сделал самым простым способом - дописал в первый же "IF" функции "handleKeyEvent" условие "and key > 0".

Работает как надо. И все сочетания срабатывают корректно.

Edited by poget

Share this post


Link to post

Short link
Share on other sites

По невыясненной причине, указанные мной сочетания (Win+Mouse) присылают код клавиши = "0".

Это движок барахлит... Опять заплатки писать... В общем то я и предполагал что-то подобное... если без конфига, то скорее всего фильтр. Код 0 прилетает скорее всего потому, что нет клавиши WIN для движка.

З.Ы. Наверное просто сделаю при распознавании KEY_NONE ==> -1, если оно конечно будет так работать... Тогда необработанное нажатие на пустое попадать не будет. Просто переписывать код в больших количествах не самая крутая идея, в либе (функция распознавания сочетаний) поменять строчку ИМХО проще.

Edited by GPCracker

Share this post


Link to post

Short link
Share on other sites

 

 

Код 0 прилетает скорее всего потому, что нет клавиши WIN для движка.

Не совсем, код для Win там имеется. Я пробовал ловить клавиши по отдельности для Win прилетает свой код, для кнопок мыши - свой, а когда используется сочетание, то последовательно прилетают коды по отдельности, а заодно, в общей куче, и нолик.

Да и такое происходит только при определенных обстоятельствах, как например в моем случае - задействованые горячие клавиши + мод который я упоминал. Хотя, вполне возможно, конфликт может вылезти и с другими модами использующими отлов клавиш.

Но это все так, рассуждения, слишком глубоко копать, проблема того не стоит. Проще поставить костыль как сделал я, с проверкой возврата 0, или как сказал ты, с присвоением KEY_NONE в -1.

Share this post


Link to post

Short link
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...