Jump to content
Korean Random
alexsv

Микрофризы

Recommended Posts

Проверяйте на 6 вариантах SWF в посте выше.
 

на чистом клиенте? только с этим одним файлом в res_mods, или на своём конфиге?

Edited by rreeedd

Share this post


Link to post

Short link
Share on other sites

6 -

5 +

4 +

3 +

2 +

1 +

вопрос... а как работает отображение иконок клана? ищется иконка независимо от состояния отображать или не отображать? 

может ли быть такая ситуация: в маркере выключено отображение иконок, но коллекция оных "большая" и при отрисовке уходит время на то чтоб таки найти иконку...

 

Проверил, клановые иконки действительно могут влиять, даже если их мало. Там есть что в коде оптимизировать.

Очередная порция на проверку.

7-9 - это разные вариации 6, на котором фризов не было.

10 - это стандартный мод, только с убранными клановыми иконками, начать лучше с него. Если фризов не будет, то ясно в чем проблема.

Прошу всех кто может проверить.

 

на чистом клиенте? только с этим одним файлом в res_mods, или на своём конфиге?

Для начала просто 10 версию проверь, не обязательно на чистом. Если фризы будут, тогда уже нужно проверять 7-10 на чистом.

Share this post


Link to post

Short link
Share on other sites
Для начала просто 10 версию проверь, не обязательно на чистом.
 

лаги в момент убийства остались, остальное всё исчезло, вроде бы.

Share this post


Link to post

Short link
Share on other sites

Микрофризы ... не... неслыхал, А вот капитальные фризы это да.

Играю пока через обычный клиен, все нормально, а при при запуске xvm-stat.exe, пипец.

20121213_1350_usa-M18_Hellcat_31_airfield.wotreplay

Share this post


Link to post

Short link
Share on other sites

лаги в момент убийства остались, остальное всё исчезло, вроде бы.

А если убрать PP.swf?

 

Микрофризы ... не... неслыхал, А вот капитальные фризы это да.

Играю пока через обычный клиен, все нормально, а при при запуске xvm-stat.exe, пипец.

Чем твое сообщение может помочь?

Share this post


Link to post

Short link
Share on other sites
лаги в момент убийства остались, остальное всё исчезло, вроде бы.

велком э клюб)

 

А если убрать PP.swf?
 

Разницы нет. Фриз при убийстве происходит в момент вывода сообщения в лог над миникартой и он есть (по-крайней мере у меня) и на чистом клиенте.

 

Микрофризы ... не... неслыхал, А вот капитальные фризы это да. Играю пока через обычный клиен, все нормально, а при при запуске xvm-stat.exe, пипец.

Пиз...ть и советовать - никакой ответственности))

и это... в твоем реплее присутствуют и лаги в чистом виде, для экспериментов  катай бой на чистом клиенте ближе к ночи когда лаги интернета/сервера сведены к минимуму

Edited by Traal

Share this post


Link to post

Short link
Share on other sites
Чем твое сообщение может помочь?

Раньше не было (например вчера все нормально было), появилось тока сегодня.

А чем помочь?  Я ХЗ,

для экспериментов катай бой на чистом клиенте

Дык на клиенте и сейчас все нормально, если запускать через WorldOfTanks.exe

Со всеми модами.

Трабла именно если через xvm-stat.exe

Edited by NikolayHAOS

Share this post


Link to post

Short link
Share on other sites

Раньше не было (например вчера все нормально было), появилось тока сегодня.

Трабла именно если через xvm-stat.exe

Перезагрузись.

Share this post


Link to post

Short link
Share on other sites

@sirmax, Не ну я не совсем нуб :)

Естественно, перезагрузка PC, проверка связи (инет от Ростелекома, 2 мегабита), смена ip.

проблема остается.

1. Попытка сделать в бою (в 2 мин. укладываюсь):

Перезагрузка PC, Заходим в игру проблема есть.

Тут же перезагрузка игры через стандартный запуск (WorldOfTanks.exe)

Все нормально, лагов нет.

2. Выход из боя и перезагрузка PC и клиента игры. (хрен с ней со статой :) )

При запуске другого боя:

повторяется следствие пункта 1.

Win7 SP1 U x64

Edited by NikolayHAOS

Share this post


Link to post

Short link
Share on other sites

Оптимизировал работу клановых иконок, теперь грузятся только если ее необходимо отобразить. То есть для режимов где "clanIcon": false не грузится.

Проверьте.



@sirmax, Не ну я не совсем нуб :)

Естественно, перезагрузка PC, проверка связи (инет от Ростелекома, 2 мегабита), смена ip.

проблема остается.

1. Попытка сделать в бою (в 2 мин. укладываюсь):

Перезагрузка PC, Заходим в игру проблема есть.

Тут же перезагрузка игры через стандартный запуск (WorldOfTanks.exe)

Все нормально, лагов нет.

2. Выход из боя и перезагрузка PC и клиента игры. (хрен с ней со статой :) )

При запуске другого боя:

повторяется следствие пункта 1.

Win7 SP1 U x64

Попробуй запустить, переключится на дестктоп, в таск-менеджере поставить приоритет xvm-stat.exe низкий, WoT.exe - высокий.

Вообще, странно - там не должно быть никакой нагрузки.

Share this post


Link to post

Short link
Share on other sites
Оптимизировал работу клановых иконок, теперь грузятся только если ее необходимо отобразить. То есть для режимов где "clanIcon": false не грузится. Проверьте.
 

вечером попробую.

 

что касается лагов при убийстве (при появлении надписи над картой) - то, может, снова какая-нибудь дребедень от WG, как было с ушами и их четырёхкратным перерисовыванием, но уже в другой флешке? повторяется просто точь в точь всё.

Share this post


Link to post

Short link
Share on other sites

вечером попробую.

 

что касается лагов при убийстве (при появлении надписи над картой) - то, может, снова какая-нибудь дребедень от WG, как было с ушами и их четырёхкратным перерисовыванием, но уже в другой флешке? повторяется просто точь в точь всё.

Давайте VMM добьем, потом за другие возьмемся. Это может быть и PP, и Battle. В принципе, я допускаю что какая-то бяка пролезла.

Share this post


Link to post

Short link
Share on other sites
Оптимизировал работу клановых иконок, теперь грузятся только если ее необходимо отобразить. То есть для режимов где "clanIcon": false не грузится. Проверьте.

"клановый засвет" прошел гладко.

Share this post


Link to post

Short link
Share on other sites

"клановый засвет" прошел гладко.

Хорошо. Надо чтобы еще народ проверил.

Можешь еще проверить с полным паком иконок?

 

Какие еще фризы остались? Что следующее делаем?

Share this post


Link to post

Short link
Share on other sites

так сразу с полным проверял, на конфиге на котором раньше фризило (кароч на полной копии папки)

След "ступень" лог убитых.

 

что касается лагов при убийстве (при появлении надписи над картой) - то, может, снова какая-нибудь дребедень от WG, как было с ушами и их четырёхкратным перерисовыванием, но уже в другой флешке? повторяется просто точь в точь всё.

как бе вот. просто я не в курсе тех переделок.

Share this post


Link to post

Short link
Share on other sites

След "ступень" лог убитых.

как бе вот. просто я не в курсе тех переделок.

Та дребедень все еще пофикшена, это в ушах было. Лишней перерисовки сейчас нет. Если на чистом клиенте это тоже проявляется, то может лучше в саппорт WG написать?

Share this post


Link to post

Short link
Share on other sites
может лучше в саппорт WG написать
 

НЕ ДАЙ БОГ!!!!!!

я с ними по предыдущим фризам переписывался с 15 апреля по 27 мая, пока вы не решили проблему за них.

толку НОЛЬ. "сделайте этот тест, сделайте тот тест, проверьте на перегрев, закройте клиент игры, откройте клиент игры, переустановите клиент, проверьте компьютер на вирусы,  закройте следующие процессы, удалите драйвера видеокарты, установите драйвера видеокарты" - это было "разогревом".

потом было:

TlXd7.png

zEwoR.png

cTpTp.png

 

И всё. Закрытая заявка без ответа :)

Share this post


Link to post

Short link
Share on other sites

@rreeedd, у ВГ в ТП работают на нищенских зарплатах глупые школьники и выпускники низкосортных учреждений (а если быть честнее, то и большинство разработчиков на тех же условиях).

Не удивительно, что максимум их способностей это танцы с бубном вокруг драйверов, перегревов, переустановок и всего остального, что можно взять "с потолка".

Они просто понятия не имеют, как на самом деле решаются эти проблемы, но чтобы получить свои копейки, они обязаны изображать видимость работы.

Edited by TwoPizza

Share this post


Link to post

Short link
Share on other sites

Это я понимаю, потому и не рекомендую всем остальным совершать ошибку и писать в ТП.

Share this post


Link to post

Short link
Share on other sites

И всё. Закрытая заявка без ответа :)

Сейчас ковыряю уши, как перерисовывалось 4 раза, так и перерисовывается. Грустно...

Моя заглушка работает.

Попробуйте эти уши (без VMM и остальных SWF), я вообще убрал перерисовку, будут фризы или нет. Если будут, то дело не в ушах.

Share this post


Link to post

Short link
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...