Jump to content
Korean Random

kupjones

User
  • Content Count

    110
  • Joined

  • Last visited

Everything posted by kupjones

  1. I see this same behavior. I turned off "In game player stats" and never got it -- but that doesnt mean much as I couldnt see playing with that turned off. Python log stops at 2020-07-17 18:11:45.779: INFO: [Scaleform] Scaleform manager: unregister movie 0000000077954D70(uid='3', swf='gui/flash/waitingTransitionsApp.swf'). 2020-07-17 18:11:45.782: INFO: [Scaleform] Destroy GUI Component: 'gui/flash/waitingTransitionsApp.swf' 2020-07-17 18:11:45.782: INFO: [Scaleform] Destroy GUI Component: 'UiRenderComponent' 2020-07-17 18:11:46.382: INFO: [Scaleform] Destroy GUI Component: 'WindowGUIComponent' 2020-07-17 18:11:46.382: INFO: [Scaleform] Destroy GUI Component: 'WindowGUIComponent'
  2. @ktulho, any response? @night_dragon_on any clues as to why one is unable to re-position the created link? some debugging in the XC file. Removing the "mouseevents" in the format section results in the removal of the "clickable column" in the login screen -- so it makes me wonder if there is not an underlying problem with how XVM is handling the mouse event registration?
  3. Need an explanation -- it is not clear what sending this file is supposed to do. Sorry
  4. Nice! Working on trying it out Error in XVM log. Got this before but it was a space issue between the function name and the passed URL arg. Now, doesnt matter. Nevermind -- no error now but link still does not work on the login screen Guess its time for me to learn how to debug python in a WOT environment -- I feel blind. Got it to work! Issue was spaces around the action commands -- those spaces were introduced in the OP demo of teh .XC options This now works thanks to @night_dragon_on. I took the original script and left everything the same (so I could get hover highlighting -- I dont knwo which component is handling that part) and instead of calling the internal browser used the function call for an external browser. What still does not work is: 1) unable to move the link to any coordinate on the display 2) the active, clickable area is a column that extends vertically to teh bottom of the screen. Not sure what controls this. There were spaces introduced in the original XC config example that was causing, I feel, most of the just-wont-work issues. Attempting to use the internal browser is a non-starter according to @night_dragon_on openBrowser.py
  5. Hmmmm, then the task is to simply display a link on the login screen/lobby, click and it will take you to an external browser. So the XVM config would need to present a clickable link, python capture a click, then pass that url to the BigWorld method. It sounds like python code here in question just needs a little update to make that work --
  6. Odd, I thought others here were able to get this python script to work -- I did try and embed a hyperlink eg,. <a href="https://wgmods.net/1778/"> Link Text</a> but the XVM parser did not like it.
  7. Correct, will not work. No mouse-over color change, no-clickthrough. This is running the DEV version XVM -- let me try the stable version BTW, your OP includes those spaces -- probably would be good to fix: " textFormat ": { "color" : "{{py: ob.highlight? 0x3B95FF | 0xD8B44E}}" , "size" : 14 }, "format" : "<u> Korean Random </u> {{py: ob.address ('https: // koreanrandom.com ')}} " , " mouseEvents " : { " mouseDown " : " openBrowser_Down " , " mouseOver " : " openBrowser_Over " , " mouseOut " : " openBrowser_Out " } } ] }}
  8. Ahhh, 2 spaces in 2 places. Ok, removed the spaces -- no more errors in XVM.log but 1> Still get no clickable link 2> cannot move the location of the address
  9. lol -- here you go -- both widgets and widgetsTemplates widgets.xc widgetsTemplates.xc
  10. Tried in both folders -- same error. It seems the script isnt registering/exporting properly. I can try again.
  11. trying to use OpenBrowser, but XVM log issues: 2020-03-22 09:40:40: [ERROR] Traceback (most recent call last): File "res_mods/mods/xfw_packages\xvm_main\python\python_macro.py", line 164, in process_python_macro (func, deterministic) = get_function(arg) File "res_mods/mods/xfw_packages\xvm_main\python\python_macro.py", line 155, in get_function (func, deterministic) = _container.get(func_name) TypeError: 'NoneType' object is not iterable arg=' ob.highlight' 2020-03-22 09:40:40: [ERROR] Traceback (most recent call last): File "res_mods/mods/xfw_packages\xvm_main\python\python_macro.py", line 164, in process_python_macro (func, deterministic) = get_function(arg) File "res_mods/mods/xfw_packages\xvm_main\python\python_macro.py", line 155, in get_function (func, deterministic) = _container.get(func_name) TypeError: 'NoneType' object is not iterable arg='ob.address ('https://wgmods.net/1778/')' OpenBrowser.py is in the D:\Games\World_of_Tanks_NA_Virgin-Mods\res_mods\configs\xvm\py_macro\xvm folder and is being compiled. Thoughts?
  12. Has the OpenBrowser script been updated to work with WOT v1.8.x? Tried it -- doesnt seem to work correctly. Thanks
  13. Yep, I saw that -- and tried it but there is something else missing. Note the inclusion of the embedded font file. I even tried changeing the font name to another system font but no luck .....
  14. Max, I truly appreciate the help -- but I have been successful in getting my images into the new format. It is the text addition that Leonid did that I am trying to get my arms around. I've uploaded the three files that I created using JPEXS - and they work great. I'm just trying to figure out how Leonid got the "textField" to show up. When the loading wheel loads into WOT the "textField" is dynamically replaced by whatever activity is going on like "Updating Garage", etc." waitingTransition.swf waiting.swf logos.swf
  15. Looking for some help that isnt strictly XVM related -- but there are alot of smart people nere so I figured I would give it a shot. I decided to play around with the SWF loading wheels and know how to not only replace the center but also sub in my own rotating wheel. One item still eludes me: 1> awhile back Leonid created his Harpoon gunsight and included a Harpoon loading wheel and he was able to modify the text that sits above the wheel (like "Updating garage, etc.) by adding text in the SWF file itself. As of patch 1.7.1 Leonids "Waiting.swf" no longer works and I wanted to see if I could recreate it -- no luck. BTW, i use JPEXS -- only free SWF decompiler I could find. Just curious if anyone knows how this works. Screenshot of the Harpoon wheel is below and I uploaded the old 'waiting.swf" file for reference. Thanks Here is his original SWF -- I tried re-creating the textField in the new 1.7.2 waiting.swf, but really no luck. waiting.swf
  16. Ah, that would make sense why I couldnt find it. That just leaves "Is it possible to modify the text that appears above the regular loading wheel"
  17. Trying this in the non_English forum as this isnt XVM related. Looking for some help. I decided to play around with the SWF loading wheels and know how to not only replace the center but also sub in my own rotating wheel. Two things still elude me: 1> the in-game store apparently has its own loading wheel (not using Logo or Waiting/Waitingtransition. Anyone know where the loading wheel originates for teh Store? 2> awhile back Leonid created his Harpoon gunsight and included a Harpoon loading wheel and he was able to modify the text that sits about the wheel (like "Updating garage, etc.) by adding text in the SWF file itself. As of patch 1.7.1 Leonids "Waiting.swf" no longer works and I wanted to see if I could recreate it -- not luck. BTW, i use JPEXS -- only free SWF decompiler I could find. Just curious if anyone can address those 2 scenarios. Screenshot of the Harpoon wheel is below Thanks Here is his original SWF -- I tried re-creating the textField in the new 1.7.2 waiting.swf, but really no luck. waiting.swf
  18. PMOD has a non-XVM version of this -- so that tells me that updating the script is possible but it seems that most feel it futile since the introduction of the anonymizer.
  19. Apparently that python code stopped working with WOT 1.7. I'm not even sure of its origins as I have carried it forward through multiple generations of WOT+XVM. thanks
  20. lol -- you know what, it doesnt! I missed the change
×
×
  • Create New...